summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Paleino <dapal@debian.org>2011-11-03 12:34:04 +0100
committerDavid Paleino <dapal@debian.org>2011-11-03 12:34:04 +0100
commitde998fd984a7ab0b31474acaf69b79164f8d656c (patch)
tree40aa1a88c5c3ebe1e8337a7c736f79534a0c6f76
parentaf0253fcf0eab803518ed07c7252d66e65d90e7e (diff)
downloadbash-completion-de998fd984a7ab0b31474acaf69b79164f8d656c.tar.gz
Removed patches merged upstream
-rw-r--r--debian/changelog3
-rw-r--r--debian/patches/00-change_completions_layout.patch94
-rw-r--r--debian/patches/series1
3 files changed, 2 insertions, 96 deletions
diff --git a/debian/changelog b/debian/changelog
index 51207b33..610c8a7c 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -5,8 +5,9 @@ bash-completion (1:1.90-1) UNRELEASED; urgency=low
sourcing of completion if symlink already exists
* Add message for users before they report a bug (debian/bug-presubj),
I'm kind of fed-up with bugs caused by acroread.sh :/
+ * Removed patches merged upstream
- -- David Paleino <dapal@debian.org> Thu, 03 Nov 2011 12:33:15 +0100
+ -- David Paleino <dapal@debian.org> Thu, 03 Nov 2011 12:33:53 +0100
bash-completion (1:1.3-3) experimental; urgency=low
diff --git a/debian/patches/00-change_completions_layout.patch b/debian/patches/00-change_completions_layout.patch
deleted file mode 100644
index 011bf9ac..00000000
--- a/debian/patches/00-change_completions_layout.patch
+++ /dev/null
@@ -1,94 +0,0 @@
-From: David Paleino <dapal@debian.org>
-Subject: move completions out of /etc/
-Origin: vendor
-Forwarded: not-needed
-
----
- Makefile.am | 10 +++++++---
- bash_completion | 2 +-
- bash_completion.sh.in | 4 ++--
- completions/perl | 4 ++--
- configure.ac | 7 +++++--
- 5 files changed, 17 insertions(+), 10 deletions(-)
-
---- bash-completion.orig/Makefile.am
-+++ bash-completion/Makefile.am
-@@ -1,13 +1,17 @@
- SUBDIRS = completions test
-
--sysconf_DATA = bash_completion
-+data_DATA = bash_completion
-
- profiledir = $(sysconfdir)/profile.d
- profile_DATA = bash_completion.sh
-
- bash_completion.sh: bash_completion.sh.in Makefile
-- sed -e 's|@sysconfdir[@]|$(sysconfdir)|' <$(srcdir)/$@.in >$@
-+ sed -e 's|@datadir[@]|$(datadir)|' <$(srcdir)/$@.in >$@
-
- CLEANFILES = bash_completion.sh
-
--EXTRA_DIST = CHANGES $(sysconf_DATA) bash_completion.sh.in
-+EXTRA_DIST = CHANGES $(data_DATA) bash_completion.sh.in
-+
-+install-exec-hook:
-+ $(MKDIR_P) $(DESTDIR)/$(sysconfdir)
-+ $(LN_S) $(datadir)/bash_completion $(DESTDIR)/$(sysconfdir)
---- bash-completion.orig/configure.ac
-+++ bash-completion/configure.ac
-@@ -1,7 +1,10 @@
- AC_PREREQ([2.59])
- AC_INIT([bash-completion], [1.3])
- AM_INIT_AUTOMAKE([foreign dist-bzip2 no-dist-gzip -Wall -Werror])
--AC_SUBST(bashcompdir, $sysconfdir/bash_completion.d)
--AC_SUBST(helpersdir, $sysconfdir/bash_completion.d/helpers)
-+AC_SUBST(datadir, $datarootdir/bash-completion)
-+AC_SUBST(bashcompdir, $datadir/completions)
-+AC_SUBST(helpersdir, $datadir/helpers)
-+AC_PROG_LN_S
-+AC_PROG_MKDIR_P
- AC_CONFIG_FILES([Makefile completions/Makefile completions/helpers/Makefile test/Makefile])
- AC_OUTPUT
---- bash-completion.orig/bash_completion.sh.in
-+++ bash-completion/bash_completion.sh.in
-@@ -4,9 +4,9 @@
- # Check for recent enough version of bash.
- bash=${BASH_VERSION%.*}; bmajor=${bash%.*}; bminor=${bash#*.}
- if [ $bmajor -gt 3 ] || [ $bmajor -eq 3 -a $bminor -ge 2 ]; then
-- if shopt -q progcomp && [ -r @sysconfdir@/bash_completion ]; then
-+ if shopt -q progcomp && [ -r @datadir@/bash_completion ]; then
- # Source completion code.
-- . @sysconfdir@/bash_completion
-+ . @datadir@/bash_completion
- fi
- fi
- unset bash bmajor bminor
---- bash-completion.orig/bash_completion
-+++ bash-completion/bash_completion
-@@ -41,7 +41,7 @@ fi
- #
- [ -n "$BASH_COMPLETION" ] || BASH_COMPLETION=/etc/bash_completion
- [ -n "$BASH_COMPLETION_DIR" ] || BASH_COMPLETION_DIR=/etc/bash_completion.d
--[ -n "$BASH_COMPLETION_COMPAT_DIR" ] || BASH_COMPLETION_COMPAT_DIR=/etc/bash_completion.d
-+[ -n "$BASH_COMPLETION_COMPAT_DIR" ] || BASH_COMPLETION_COMPAT_DIR=/var/lib/bash-completion/
- readonly BASH_COMPLETION BASH_COMPLETION_DIR BASH_COMPLETION_COMPAT_DIR
-
- # Set a couple of useful vars
---- bash-completion.orig/completions/perl
-+++ bash-completion/completions/perl
-@@ -4,13 +4,13 @@ have perl &&
- {
- _perlmodules()
- {
-- COMPREPLY=( $( compgen -P "$prefix" -W "$( $1 ${BASH_SOURCE[0]%/*}/helpers/perl modules $cur )" -- "$cur" ) )
-+ COMPREPLY=( $( compgen -P "$prefix" -W "$( $1 /usr/share/bash-completion/helpers/perl modules $cur )" -- "$cur" ) )
- __ltrim_colon_completions "$prefix$cur"
- }
-
- _perlfunctions()
- {
-- COMPREPLY=( $( compgen -P "$prefix" -W "$( ${BASH_SOURCE[0]%/*}/helpers/perl functions $cur )" -- "$cur" ) )
-+ COMPREPLY=( $( compgen -P "$prefix" -W "$( /usr/share/bash-completion/helpers/perl functions $cur )" -- "$cur" ) )
- }
-
- _perl()
diff --git a/debian/patches/series b/debian/patches/series
deleted file mode 100644
index ceac9ce2..00000000
--- a/debian/patches/series
+++ /dev/null
@@ -1 +0,0 @@
-00-change_completions_layout.patch