summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Paleino <dapal@debian.org>2011-11-03 12:42:39 +0100
committerDavid Paleino <dapal@debian.org>2011-11-03 12:45:52 +0100
commit75a48b26676a4912c6984c7822fecdfcf460bffe (patch)
treefccdfabc001cf60fbf63d9725f6ed72691085474
parent573e02a82b3bb010f416b4138d23a10618a9eafc (diff)
downloadbash-completion-75a48b26676a4912c6984c7822fecdfcf460bffe.tar.gz
Drop trigger-based completion loading
-rw-r--r--debian/README.Debian5
-rw-r--r--debian/changelog3
-rw-r--r--debian/dirs1
-rwxr-xr-xdebian/extra/cron/bash-completion6
-rwxr-xr-xdebian/extra/scripts/update-bash-completion81
-rw-r--r--debian/extra/scripts/update-bash-completion.120
-rw-r--r--debian/install3
-rw-r--r--debian/manpages1
-rw-r--r--debian/triggers5
9 files changed, 2 insertions, 123 deletions
diff --git a/debian/README.Debian b/debian/README.Debian
index d478c4e3..70403762 100644
--- a/debian/README.Debian
+++ b/debian/README.Debian
@@ -3,11 +3,6 @@ bash-completion for Debian
Completions are kept in /usr/share/bash-completions/completions.
- When a package is installed, the update-bash-completion(1) script creates
- symlinks under /var/lib/bash-completion/. If you want to enable a specific
- completion, just symlink it from the aforementioned directory to
- /etc/bash_completion.d/ -- and then open a new shell.
-
/etc/bash_completion.d/ is being kept for compatibility reasons; but will
disappear in future. If you're a package maintainer, you're encouraged to
use dh_bash-completion(1), which will take care of installing third-party
diff --git a/debian/changelog b/debian/changelog
index 610c8a7c..e8d1d619 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -6,8 +6,9 @@ bash-completion (1:1.90-1) UNRELEASED; urgency=low
* Add message for users before they report a bug (debian/bug-presubj),
I'm kind of fed-up with bugs caused by acroread.sh :/
* Removed patches merged upstream
+ * Drop trigger-based completion loading
- -- David Paleino <dapal@debian.org> Thu, 03 Nov 2011 12:33:53 +0100
+ -- David Paleino <dapal@debian.org> Thu, 03 Nov 2011 12:42:20 +0100
bash-completion (1:1.3-3) experimental; urgency=low
diff --git a/debian/dirs b/debian/dirs
index bbe08bdd..ce73da06 100644
--- a/debian/dirs
+++ b/debian/dirs
@@ -3,4 +3,3 @@ usr/bin
usr/share/doc/bash
usr/share/doc/bash-completion
usr/share/perl5/Debian/Debhelper/Sequence/
-var/lib/bash-completion
diff --git a/debian/extra/cron/bash-completion b/debian/extra/cron/bash-completion
deleted file mode 100755
index 0e596f14..00000000
--- a/debian/extra/cron/bash-completion
+++ /dev/null
@@ -1,6 +0,0 @@
-#!/bin/sh
-
-[ -x /usr/sbin/update-bash-completion ] || exit 0
-
-rm -rf /var/lib/bash-completion/*
-/usr/sbin/update-bash-completion
diff --git a/debian/extra/scripts/update-bash-completion b/debian/extra/scripts/update-bash-completion
deleted file mode 100755
index 42b043a4..00000000
--- a/debian/extra/scripts/update-bash-completion
+++ /dev/null
@@ -1,81 +0,0 @@
-#!/bin/bash
-# install relevant completions, by sourcing every scriptlet
-# found in a given directory, and symlinking those matching
-# an installed command to another directory
-
-have()
-{
- PATH=$PATH:/sbin:/usr/sbin:/usr/local/sbin type $1 &>/dev/null
-}
-
-usage()
-{
- echo "usage: $0 <completion_dir> [installation_dir]"
-}
-
-while getopts ":h" flag; do
- case $flag in
- h) usage; exit 0;;
- esac
-done
-
-shift $((OPTIND - 1))
-
-completion_dir=/usr/share/bash-completion/completions/
-if [ -z "$completion_dir" ]; then
- echo "missing completion directory"
- usage
- exit 1
-fi
-if [ ! -d $completion_dir ]; then
- echo "invalid directory $completion_dir"
- usage
- exit 1
-fi
-
-installation_dir=/var/lib/bash-completion/
-if [ ! -d $installation_dir ]; then
- echo "invalid directory $installation_dir"
- usage
- exit 1
-fi
-
-# many scripts require this
-shopt -s extglob
-
-# and some require this also
-UNAME=$(uname -s)
-UNAME=${UNAME/CYGWIN_*/Cygwin}
-
-case $UNAME in
- Linux|GNU|GNU/*) USERLAND=GNU ;;
- *) USERLAND=$UNAME ;;
-esac
-
-for script in $completion_dir/*; do
- dest=$installation_dir/$(basename $script)
-
- if [ -L "$dest" ]; then
- continue
- fi
-
- # reset completion
- complete -r
-
- # source script
- source $script 2>/dev/null
-
- # check completion output
- output=$(complete -p)
-
- if [ -z "$output" ]; then
- continue
- fi
-
- if [ -n "$installation_dir" ]; then
- ln -sf $script $dest
- else
- echo "$script OK"
- fi
-
-done
diff --git a/debian/extra/scripts/update-bash-completion.1 b/debian/extra/scripts/update-bash-completion.1
deleted file mode 100644
index b5d1ecc9..00000000
--- a/debian/extra/scripts/update-bash-completion.1
+++ /dev/null
@@ -1,20 +0,0 @@
-.TH UPDATE-BASH-COMPLETION 1 "Apr 25, 2011"
-.SH NAME
-update-bash-completion \- update completions symlinks
-.SH SYNOPSIS
-.B update-bash-completion
-.SH DESCRIPTION
-This manual page documents briefly the \fBupdate-bash-completion\fR command.
-.PP
-\fBupdate-bash-completion\fP is used to update the symbolic links pointing to
-bash completions for installed programs.
-.PP
-It is usually run during after the installation of any package installing
-executables under \fI/usr/bin\fR, \fI/usr/sbin\fR, \fI/usr/games\fR,
-\fI/bin\fR or \fI/sbin\fR, but it may also be run manually.
-.SH AUTHOR
-update-bash-completion was written by Guillaume Rousse <Guillaume.Rousse@inria.fr>,
-and was adapted for Debian by David Paleino <dapal@debian.org>.
-.PP
-This manual page was written by David Paleino <dapal@debian.org>,
-for the Debian project (and may be used by others).
diff --git a/debian/install b/debian/install
index 7e7074a2..bcda3394 100644
--- a/debian/install
+++ b/debian/install
@@ -1,5 +1,2 @@
debian/extra/debhelper/dh_bash-completion /usr/bin/
debian/extra/debhelper/bash_completion.pm /usr/share/perl5/Debian/Debhelper/Sequence/
-
-debian/extra/scripts/update-bash-completion /usr/sbin/
-debian/extra/cron/bash-completion /etc/cron.monthly/
diff --git a/debian/manpages b/debian/manpages
index 1195bf51..f41aae72 100644
--- a/debian/manpages
+++ b/debian/manpages
@@ -1,2 +1 @@
debian/extra/debhelper/dh_bash-completion.1
-debian/extra/scripts/update-bash-completion.1
diff --git a/debian/triggers b/debian/triggers
deleted file mode 100644
index 0f8572da..00000000
--- a/debian/triggers
+++ /dev/null
@@ -1,5 +0,0 @@
-interest /usr/bin
-interest /usr/sbin
-interest /usr/games
-interest /bin
-interest /sbin