summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Paleino <d.paleino@gmail.com>2009-10-10 17:45:28 +0200
committerDavid Paleino <d.paleino@gmail.com>2009-10-10 17:45:28 +0200
commitcdc6aab62fd44cc93154de73993f05f941ce74cb (patch)
treec142ce0da5785fba964943b08f6180c1236cf09a
parent897162a2cb634b16b456f208afb9ccede836c29d (diff)
downloadbash-completion-cdc6aab62fd44cc93154de73993f05f941ce74cb.tar.gz
debian/rules: rewritten using dh7
-rw-r--r--debian/changelog3
-rwxr-xr-xdebian/rules47
2 files changed, 20 insertions, 30 deletions
diff --git a/debian/changelog b/debian/changelog
index 6a65d720..aa0b87b6 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -7,11 +7,12 @@ bash-completion (1:1.1-1) UNRELEASED; urgency=low
* debian/rules:
- passing debian/CHANGES to dh_installchangelogs, it's missing from
upstream tarball :(
+ - rewritten using dh7
* debian/control:
- debhelper Build-Dependency bumped to >= 7.0.50
* debian/compat bumped to 7
- -- David Paleino <d.paleino@gmail.com> Sat, 10 Oct 2009 17:34:34 +0200
+ -- David Paleino <d.paleino@gmail.com> Sat, 10 Oct 2009 17:45:06 +0200
bash-completion (1:1.0-3) unstable; urgency=low
diff --git a/debian/rules b/debian/rules
index 1188ab82..29baf074 100755
--- a/debian/rules
+++ b/debian/rules
@@ -4,11 +4,15 @@
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
-include /usr/share/quilt/quilt.make
-
VERSION=$(shell parsechangelog | grep ^Version | awk -F": " '{print $$2}' | cut -d"-" -f1)
d = debian/bash-completion
+override_dh_compress:
+ dh_compress -Xcontrib
+
+override_dh_installchangelogs:
+ dh_installchangelogs debian/CHANGES
+
dh_bash-completion.1: debian/extra/dh_bash-completion
pod2man \
--center "Bash-Completion Debhelper" \
@@ -16,42 +20,27 @@ dh_bash-completion.1: debian/extra/dh_bash-completion
$< > debian/extra/$@
build: build-stamp
-build-stamp: $(QUILT_STAMPFN)
- dh_testdir
+build-stamp:
+ dh build
touch $@
-clean: unpatch
- dh_testdir
- dh_testroot
- dh_clean build-stamp
-
-install: build
- dh_testdir
- dh_testroot
- dh_clean -k
- dh_installdirs
- dh_install
+clean:
+ dh $@
+install: install-stamp
+install-stamp: build
+ dh install
for i in mtx; do \
rm -vf debian/bash-completion/etc/bash_completion.d/$$i; \
done
-
- dh_link
+ touch $@
binary-indep: build install
- dh_testdir
- dh_testroot
- dh_installchangelogs debian/CHANGES
- dh_installdocs README TODO AUTHORS
- dh_installman
- dh_compress -Xcontrib
- dh_fixperms
- dh_installdeb
- dh_gencontrol
- dh_md5sums
- dh_builddeb
+ dh $@
+
-binary-arch: build install
+binary-arch:
binary: binary-indep binary-arch
+
.PHONY: build clean binary-indep binary-arch binary install