summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml4
1 files changed, 4 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 0a92130..df9eba7 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -3,12 +3,16 @@ target-version = "py37"
select = [
"B",
"C",
+ "E",
]
ignore = [
"C901", # Complexity
"E501", # Line length
+ "E731", # Do not assign a lambda expression (we use them on purpose)
"E741", # Ambiguous variable name
]
extend-exclude = [
"tests/messages/data",
]
+[tool.ruff.per-file-ignores]
+"scripts/import_cldr.py" = ["E402"]