summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStefano Lattarini <stefano.lattarini@gmail.com>2012-10-27 19:18:48 +0200
committerStefano Lattarini <stefano.lattarini@gmail.com>2012-10-27 19:18:48 +0200
commit0faf1588b9e820c20351c92afa44c9d0e8a3a412 (patch)
treeb462d43917b2fc7f64c83c9b820aaa82e37744d8 /configure.ac
parent57770a2cce19e74b3a90f2bf60db2af5b6fee5d8 (diff)
parentbf016cee0efa2dd3594513791f588b47fa5c456f (diff)
downloadautomake-0faf1588b9e820c20351c92afa44c9d0e8a3a412.tar.gz
Merge branch 'maint'
* maint: configure: correctly identify missing GNU compilers as such
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac40
1 files changed, 25 insertions, 15 deletions
diff --git a/configure.ac b/configure.ac
index 78cdfc081..90985da11 100644
--- a/configure.ac
+++ b/configure.ac
@@ -529,9 +529,11 @@ if test $am_CC_is_GNU = yes; then
else
AC_CHECK_TOOLS([GNU_CC], [gcc], [false])
fi
-AS_IF([AM_RUN_LOG([$GNU_CC --version && $GNU_CC -v])], [],
- [AC_MSG_WARN([botched installation for GNU C compiler])
- _AM_SKIP_COMP_TESTS([GNU C])])
+if test "$GNU_CC" != false; then
+ AS_IF([AM_RUN_LOG([$GNU_CC --version && $GNU_CC -v])], [],
+ [AC_MSG_WARN([botched installation for GNU C compiler])
+ _AM_SKIP_COMP_TESTS([GNU C])])
+fi
# GNU C++ compiler.
AC_ARG_VAR([GNU_CXX], [GNU C++ compiler])
@@ -543,9 +545,11 @@ if test $am_CXX_is_GNU = yes; then
else
AC_CHECK_TOOLS([GNU_CXX], [g++ gpp], [false])
fi
-AS_IF([AM_RUN_LOG([$GNU_CXX --version && $GNU_CXX -v])], [],
- [AC_MSG_WARN([botched installation for GNU C++ compiler])
- _AM_SKIP_COMP_TESTS([GNU C++])])
+if test "$GNU_CXX" != false; then
+ AS_IF([AM_RUN_LOG([$GNU_CXX --version && $GNU_CXX -v])], [],
+ [AC_MSG_WARN([botched installation for GNU C++ compiler])
+ _AM_SKIP_COMP_TESTS([GNU C++])])
+fi
# GNU Fortran compiler.
AC_ARG_VAR([GNU_FC], [GNU Fortran compiler])
@@ -557,9 +561,11 @@ if test $am_FC_is_GNU = yes; then
else
AC_CHECK_TOOLS([GNU_FC], [gfortran], [false])
fi
-AS_IF([AM_RUN_LOG([$GNU_FC --version && $GNU_FC -v])], [],
- [AC_MSG_WARN([botched installation for GNU Fortran compiler])
- _AM_SKIP_COMP_TESTS([GNU Fortran])])
+if test "$GNU_FC" != false; then
+ AS_IF([AM_RUN_LOG([$GNU_FC --version && $GNU_FC -v])], [],
+ [AC_MSG_WARN([botched installation for GNU Fortran compiler])
+ _AM_SKIP_COMP_TESTS([GNU Fortran])])
+fi
# GNU Fortran 77 compiler.
AC_ARG_VAR([GNU_F77], [GNU Fortran 77 compiler])
@@ -571,17 +577,21 @@ if test $am_F77_is_GNU = yes; then
else
AC_CHECK_TOOLS([GNU_F77], [g77 gfortran], [false])
fi
-AS_IF([AM_RUN_LOG([$GNU_F77 --version && $GNU_F77 -v])], [],
- [AC_MSG_WARN([botched installation for GNU Fortran 77 compiler])
- _AM_SKIP_COMP_TESTS([GNU Fortran 77])])
+if test "$GNU_F77" != false; then
+ AS_IF([AM_RUN_LOG([$GNU_F77 --version && $GNU_F77 -v])], [],
+ [AC_MSG_WARN([botched installation for GNU Fortran 77 compiler])
+ _AM_SKIP_COMP_TESTS([GNU Fortran 77])])
+fi
# GNU Java compiler.
AC_ARG_VAR([GNU_GCJ], [GNU Java compiler])
AC_ARG_VAR([GNU_GCJFLAGS], [GNU Java compiler flags])
AC_CHECK_TOOLS([GNU_GCJ], [gcj], [false])
-AS_IF([AM_RUN_LOG([$GNU_GCJ --version && $GNU_GCJ -v])], [],
- [AC_MSG_WARN([botched installation for GNU Java compiler])
- _AM_SKIP_COMP_TESTS([GNU Java])])
+if test "$GNU_GCJ" != false; then
+ AS_IF([AM_RUN_LOG([$GNU_GCJ --version && $GNU_GCJ -v])], [],
+ [AC_MSG_WARN([botched installation for GNU Java compiler])
+ _AM_SKIP_COMP_TESTS([GNU Java])])
+fi
# If we have been able to find at least a working compiler above, we
# know what the object and executable extensions for this platform are.