summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorStefano Lattarini <stefano.lattarini@gmail.com>2012-12-08 21:45:53 +0100
committerStefano Lattarini <stefano.lattarini@gmail.com>2012-12-09 10:20:06 +0100
commitd47000c6c7fe974919cb6e256fcc866eb6b19273 (patch)
tree2f13f52f8718efc1aa9d869239c1c03e3ff58b07 /Makefile.am
parent71ce1b47ea7b180dfbfd09d7654d262c26b727bf (diff)
downloadautomake-d47000c6c7fe974919cb6e256fcc866eb6b19273.tar.gz
maintcheck: prefer '$(am__cd)' over plain 'cd'
In a couple of rules in out own build system, as suggested by the maintainer check 'sc_cd_relative_dir'. * Makefile.am (web-manuals, clean_texinfo_clutter_cmd): Adjust. Signed-off-by: Stefano Lattarini <stefano.lattarini@gmail.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index ee1fdceab..22a8fbd14 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1000,8 +1000,8 @@ fetch:
# The gendocs.sh script sadly leaves TeX and Texinfo auxiliary files
# in the directory where it's invoked.
clean_texinfo_clutter_cmd = \
- cd doc && rm -f *.ac *.aux *.cm *.cp *.cps *.fn *.fns *.ky \
- *.log *.op *.pg *.toc *.tp *.tr *.vr *.vrs
+ $(am__cd) doc && rm -f *.ac *.aux *.cm *.cp *.cps *.fn *.fns *.ky \
+ *.log *.op *.pg *.toc *.tp *.tr *.vr *.vrs
clean-web-manuals:
$(AM_V_at)rm -rf doc/web-manuals
@@ -1014,7 +1014,7 @@ web-manuals:
$(AM_V_at)rm -rf doc/web-manuals
$(AM_V_GEN): \
## The gendocs.sh script only works from the srcdir, sadly.
- && cd $(srcdir)/doc \
+ && $(am__cd) $(srcdir)/doc \
&& GENDOCS_TEMPLATE_DIR=../lib \
&& export GENDOCS_TEMPLATE_DIR \
## Try to respect silent rules.