summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorStefano Lattarini <stefano.lattarini@gmail.com>2012-02-16 10:33:30 +0100
committerStefano Lattarini <stefano.lattarini@gmail.com>2012-02-16 10:33:57 +0100
commitdb5ddc2bfceeb4470d02c2ff2375cf5900415493 (patch)
tree123596d0bd39ffdc9b4802e303cc0dda01f875c8 /Makefile.am
parent8dd5009996be46270a58bde8be4343410ea5df51 (diff)
downloadautomake-db5ddc2bfceeb4470d02c2ff2375cf5900415493.tar.gz
update-copyright: don't touch files synced from external packages
* Makefile.am (update-copyright): Do not update copyright years of files synced from external packages, as given by the '$(FETCHFILES)' variable. Silence the recipe since we are at it.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 76c3e6986..d02731f26 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -821,5 +821,9 @@ update_copyright_env = \
.PHONY: update-copyright
update-copyright:
- git ls-files | grep -Ev 'COPYING|INSTALL' \
+ $(AM_V_GEN)excluded_re=`echo $(FETCHFILES) \
+ | sed -e 's|^|lib/|' -e 's| | lib/|g' -e 's, ,|,g'`; \
+ $(GIT) ls-files \
+ | grep -Ev '/(COPYING|INSTALL)' \
+ | grep -Ev "^($$excluded_re)$$" \
| $(update_copyright_env) xargs $(srcdir)/lib/$@