summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 4 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index 2d831770..c6291b30 100644
--- a/configure.ac
+++ b/configure.ac
@@ -16,8 +16,7 @@
# You should have received a copy of the GNU General Public License
# along with this program. If not, see <http://www.gnu.org/licenses/>.
-# We need AC_CONFIG_TESTDIR, AC_PROG_SED, AC_PROG_GREP.
-AC_PREREQ([2.60])
+AC_PREREQ([2.62])
AC_INIT([GNU Autoconf],
m4_esyscmd([build-aux/git-version-gen .tarball-version]),
@@ -205,19 +204,14 @@ AC_PROG_MAKE_CASE_SENSITIVE
## Conclusion. ##
## ------------ ##
-dnl Allow maintainer rules under GNU make even in VPATH builds. This does
-dnl not work in autoconf 2.61 or earlier, but we don't want to require
-dnl unreleased autoconf during bootstrap, hence the version test.
-dnl TODO remove the version check once we depend on autoconf 2.62.
+dnl Allow maintainer rules under GNU make even in VPATH builds.
dnl Meanwhile, we must use a shell variable so that we bypass automake's
dnl attempts to remove the sole copy of GNUmakefile in a non-VPATH build
dnl during 'make distclean'.
dnl TODO avoid the shell variable once automake is fixed.
GNUmakefile=GNUmakefile
-m4_if(m4_version_compare([2.61a.100],
- m4_defn([m4_PACKAGE_VERSION])), [1], [],
- [AC_CONFIG_LINKS([$GNUmakefile:$GNUmakefile], [],
- [GNUmakefile=$GNUmakefile])])
+AC_CONFIG_LINKS([$GNUmakefile:$GNUmakefile], [],
+ [GNUmakefile=$GNUmakefile])
AC_CONFIG_FILES([Makefile doc/Makefile
lib/Makefile lib/Autom4te/Makefile lib/autoscan/Makefile