summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEric Blake <eblake@redhat.com>2012-03-07 10:47:01 -0700
committerEric Blake <eblake@redhat.com>2012-03-07 10:50:09 -0700
commitda4121067329547fcbb9b1765c65f884599b2631 (patch)
tree57216946dda5ee60234c59ae3b34883a928ce694 /configure.ac
parent220f8c240df11dcf0829d86d33e3f354fe87e0ad (diff)
downloadautoconf-da4121067329547fcbb9b1765c65f884599b2631.tar.gz
build: require perl 5.6
This reduces the implicit requirement from 5.6.2 back to 5.6, while raising the explicit requirement to match the actual code. * configure.ac (PERL): Fail up front if perl is too old. * NEWS: Document this. * README: Likewise. * README-hacking: Likewise. * lib/Autom4te/ChannelDefs.pm: Bump requirement. * lib/Autom4te/General.pm: Relax requirement.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 5bf7b9d0..280cc0e5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -135,8 +135,8 @@ AC_SUBST([PERL])dnl
if test "$PERL" = no; then
AC_MSG_ERROR([perl is not found])
fi
-$PERL -e 'require 5.005_03;' || {
- AC_MSG_ERROR([Perl 5.005_03 or better is required])
+$PERL -e 'require 5.006;' || {
+ AC_MSG_ERROR([Perl 5.006 or better is required])
}
# Find out whether the system supports flock