summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlexandre Duret-Lutz <adl@gnu.org>2003-09-13 22:00:36 +0000
committerAlexandre Duret-Lutz <adl@gnu.org>2003-09-13 22:00:36 +0000
commit033b8cecbdc453dddd1c06f542a4f4281668dacf (patch)
treecf9b2cf18769eb12b8d1f3bc9a96298f6ca26b2e /Makefile.am
parent68085c7b7661cc5bc788e648496344985fc79997 (diff)
downloadautoconf-033b8cecbdc453dddd1c06f542a4f4281668dacf.tar.gz
* Makefile.am (autom4te-update, autom4te_files): Fetch Struct.pm
and XFile.pm from Automake. * lib/Autom4te/XFile.pm: Update from Automake.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index b24b06df..fb30c00e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -68,7 +68,9 @@ automake_cvsargs = \
autom4te_files = \
Autom4te/Configure_ac.pm \
Autom4te/Channels.pm \
- Autom4te/FileUtils.pm
+ Autom4te/FileUtils.pm \
+ Autom4te/Struct.pm \
+ Autom4te/XFile.pm
autom4te-update:
rm -rf Fetchdir > /dev/null 2>&1
@@ -78,6 +80,8 @@ autom4te-update:
$(WGET) $(automake_cvsweb)/lib/Automake/Configure_ac.pm?$(automake_cvsargs) -O Autom4te/Configure_ac.pm; \
$(WGET) $(automake_cvsweb)/lib/Automake/Channels.pm?$(automake_cvsargs) -O Autom4te/Channels.pm; \
$(WGET) $(automake_cvsweb)/lib/Automake/FileUtils.pm?$(automake_cvsargs) -O Autom4te/FileUtils.pm; \
+ $(WGET) $(automake_cvsweb)/lib/Automake/Struct.pm?$(automake_cvsargs) -O Autom4te/Struct.pm; \
+ $(WGET) $(automake_cvsweb)/lib/Automake/XFile.pm?$(automake_cvsargs) -O Autom4te/XFile.pm; \
:)
perl -pi -e 's/Automake::/Autom4te::/g' Fetchdir/Autom4te/*.pm
for file in $(autom4te_files); do \