summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorEric Blake <ebb9@byu.net>2009-04-21 06:41:24 -0600
committerEric Blake <ebb9@byu.net>2009-04-21 06:51:35 -0600
commitc474ab908444e2d6703bd22e4122e551fcdaa96b (patch)
tree34dd1ed2a9929f69d2ead22ea7970ae714ff5ab9 /Makefile.am
parente430ff0ca663b6ebbd9dafa8909ff07cc0273135 (diff)
downloadautoconf-c474ab908444e2d6703bd22e4122e551fcdaa96b.tar.gz
Shuffle maintainer-specific rules.
* Makefile.am (maintainer-check-tests): Delete. (autom4te-update): Move... * cfg.mk (autom4te-update): ...here. (fetch): Depend on autom4te-update. Split... (gnulib-update): ...into new rule. Import move-if-change from gnulib. * maint.mk (maintainer-distcheck): Absorb former maintainer-check rule. * build-aux/move-if-change: New file, undistributed. * .gitattributes: Handle new upstream file. * .gitignore: Ignore maintainer cruft. * HACKING: Update maintainer instructions. * build-aux/config.guess: Update from upstream. * build-aux/config.sub: Likewise. * build-aux/gendocs.sh: Likewise. * build-aux/texinfo.tex: Likewise. * doc/gendocs_template: Likewise. * doc/standards.texi: Likewise. Signed-off-by: Eric Blake <ebb9@byu.net>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am36
1 files changed, 0 insertions, 36 deletions
diff --git a/Makefile.am b/Makefile.am
index 919a2986..78367354 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -46,42 +46,6 @@ $(srcdir)/INSTALL: $(top_srcdir)/doc/install.texi
$(top_srcdir)/doc/install.texi
endif
-## maintainer-check ##
-maintainer-check: maintainer-check-tests
-maintainer-check-tests: all
- cd tests && $(MAKE) $(AM_MAKEFLAGS) maintainer-check
-
-
-## ----------------------------------- ##
-## Updating Perl files from Automake. ##
-## ----------------------------------- ##
-
-WGET = wget
-WGETFLAGS = -C off
-
-## Fetch the latest versions of files we care about.
-automake_gitweb = \
- http://git.savannah.gnu.org/gitweb/?p=automake.git;a=blob_plain;hb=HEAD;
-autom4te_files = \
- Autom4te/Configure_ac.pm \
- Autom4te/Channels.pm \
- Autom4te/FileUtils.pm \
- Autom4te/Struct.pm \
- Autom4te/XFile.pm
-
-autom4te-update:
- rm -f -r Fetchdir > /dev/null 2>&1
- mkdir -p Fetchdir/Autom4te
- for file in $(autom4te_files); do \
- infile=`echo $$file | sed 's/Autom4te/Automake/g'`; \
- $(WGET) $(WGET_FLAGS) \
- "$(automake_gitweb)f=lib/$$infile" \
- -O "Fetchdir/$$file" || exit; \
- done
- perl -pi -e 's/Automake::/Autom4te::/g' Fetchdir/Autom4te/*.pm
- for file in $(autom4te_files); do \
- $(move_if_change) Fetchdir/$$file $(srcdir)/lib/$$file || exit; \
- done
# Version string management. There are two files to be aware of:
# .tarball-version - present only in a distribution tarball, and not in