summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorEric Blake <ebb9@byu.net>2008-04-03 16:45:11 -0600
committerEric Blake <ebb9@byu.net>2008-04-03 16:57:56 -0600
commit1fda5799d3763286e53673bb1a0174c6c3518a6c (patch)
tree30fa5516d908bdf81c23b1e60cf4110186ee55c9 /Makefile.am
parentf752252f504a1487c16322b23a6ae0084ebb4b46 (diff)
downloadautoconf-1fda5799d3763286e53673bb1a0174c6c3518a6c.tar.gz
Fix version number generation in man pages.
* Makefile.am (EXTRA_DIST): Distribute .version. (.version): New rule. * man/Makefile.am (common_dep): Depend on .version, not configure.ac. (.x.1): Use package name for version string. * GNUmakefile [!_have-Makefile]: Sync from upstream, again. * build-aux/git-version-gen: Sync from upstream. Signed-off-by: Eric Blake <ebb9@byu.net>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am20
1 files changed, 19 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 86b64910..5a9f5f73 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -27,7 +27,7 @@ EXTRA_DIST = ChangeLog.0 ChangeLog.1 ChangeLog.2 \
BUGS \
GNUmakefile maint.mk cfg.mk \
build-aux/git-version-gen \
- build-aux/announce-gen .prev-version
+ build-aux/announce-gen .prev-version .version
MAINTAINERCLEANFILES = $(srcdir)/INSTALL
@@ -88,6 +88,24 @@ autom4te-update:
$(move_if_change) Fetchdir/$$file $(srcdir)/lib/$$file || exit; \
done
+# Version string management. There are two files to be aware of:
+# .tarball-version - present only in a distribution tarball, and not in
+# a checked-out repository. Created with contents that were learned at
+# the last time autoconf was run, and used by git-version-gen. Must not
+# be present in either $(srcdir) or $(builddir) for git-version-gen to
+# give accurate answers during normal development with a checked out tree,
+# but must be present in a tarball when there is no version control system.
+# Therefore, it cannot be used in any dependencies. GNUmakefile has
+# hooks to force a reconfigure at distribution time to get the value
+# correct, without penalizing normal development with extra reconfigures.
+# .version - present in a checked-out repository and in a distribution
+# tarball. At least as current as the most recent .tarball-version
+# creation. Usable in dependencies, particularly for files that don't
+# want to depend on config.h but do want to track version changes.
+BUILT_SOURCES = $(top_srcdir)/.version
+$(top_srcdir)/.version:
+ echo $(VERSION) > $@-t && mv $@-t $@
+
# Arrange so that .tarball-version appears only in distribution tarballs,
# never in a checked-out repository.
dist-hook: