summaryrefslogtreecommitdiff
path: root/tclap-1.2.1/docs/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tclap-1.2.1/docs/Makefile.am')
-rw-r--r--tclap-1.2.1/docs/Makefile.am31
1 files changed, 31 insertions, 0 deletions
diff --git a/tclap-1.2.1/docs/Makefile.am b/tclap-1.2.1/docs/Makefile.am
new file mode 100644
index 0000000..8315b36
--- /dev/null
+++ b/tclap-1.2.1/docs/Makefile.am
@@ -0,0 +1,31 @@
+
+if DOC
+
+all:
+ @DOXYGEN@ Doxyfile
+
+else
+
+all:
+
+endif
+
+EXTRA_DIST = manual.xml
+dist_doc_DATA = index.html manual.html style.css
+docdir = ${datadir}/doc/${PACKAGE}
+
+install-data-local :
+ $(mkdir_p) $(DESTDIR)$(docdir)
+ cp -R $(abs_srcdir)/html $(DESTDIR)$(docdir)
+
+uninstall-local :
+ chmod -R +w $(DESTDIR)$(docdir)
+ rm -rf $(DESTDIR)$(docdir)
+
+dist-hook :
+ $(mkdir_p) $(distdir)
+ cp -R $(abs_srcdir)/html $(distdir)
+
+clean-local:
+ $(RM) -rf $(abs_srcdir)/html/*
+