summaryrefslogtreecommitdiff
path: root/PluginStructuralTest/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'PluginStructuralTest/CMakeLists.txt')
-rw-r--r--PluginStructuralTest/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/PluginStructuralTest/CMakeLists.txt b/PluginStructuralTest/CMakeLists.txt
index aae04c4..115408a 100644
--- a/PluginStructuralTest/CMakeLists.txt
+++ b/PluginStructuralTest/CMakeLists.txt
@@ -9,6 +9,7 @@ set(EXECUTABLE_OUTPUT_PATH ../../bin/)
set(LIBRARY_OUTPUT_PATH ../plugins)
set(DBUS_FOLDER ${CMAKE_SOURCE_DIR}/../dbusInterfaces)
set(DOC_OUTPUT_PATH ${CMAKE_SOURCE_DIR}/../doc/PluginTest)
+set(DOCUMENT $ENV{gendoc})
cmake_policy(SET CMP0015 NEW)
@@ -60,9 +61,11 @@ TARGET_LINK_LIBRARIES(TestPlugin
#add a target to generate API documentation with Doxygen
find_package(Doxygen)
if(DOXYGEN_FOUND)
+if(DOCUMENT)
configure_file(Doxyfile.in ${PROJECT_BINARY_DIR}/Doxyfile @ONLY IMMEDIATE)
add_custom_target (Docs ALL
COMMAND ${DOXYGEN_EXECUTABLE} ${PROJECT_BINARY_DIR}/Doxyfile WORKING_DIRECTORY ${DOC_OUTPUT_PATH}
SOURCES ${PROJECT_BINARY_DIR}/Doxyfile)
+endif(DOCUMENT)
endif(DOXYGEN_FOUND)