summaryrefslogtreecommitdiff
path: root/PluginRoutingInterfaceAsync/test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'PluginRoutingInterfaceAsync/test/CMakeLists.txt')
-rw-r--r--PluginRoutingInterfaceAsync/test/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/PluginRoutingInterfaceAsync/test/CMakeLists.txt b/PluginRoutingInterfaceAsync/test/CMakeLists.txt
index 434c6f9..8df4bdd 100644
--- a/PluginRoutingInterfaceAsync/test/CMakeLists.txt
+++ b/PluginRoutingInterfaceAsync/test/CMakeLists.txt
@@ -30,7 +30,9 @@ IF(WITH_DLT)
pkg_check_modules(DLT REQUIRED automotive-dlt)
ENDIF(WITH_DLT)
-pkg_check_modules(SQLITE REQUIRED sqlite3)
+IF(WITH_DATABASE_STORAGE)
+ pkg_check_modules(SQLITE REQUIRED sqlite3)
+ENDIF(WITH_DATABASE_STORAGE)
INCLUDE_DIRECTORIES(
${STD_INCLUDE_DIRS}