summaryrefslogtreecommitdiff
path: root/PluginControlInterface/test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'PluginControlInterface/test/CMakeLists.txt')
-rw-r--r--PluginControlInterface/test/CMakeLists.txt21
1 files changed, 20 insertions, 1 deletions
diff --git a/PluginControlInterface/test/CMakeLists.txt b/PluginControlInterface/test/CMakeLists.txt
index 87e2e1b..3dc5d08 100644
--- a/PluginControlInterface/test/CMakeLists.txt
+++ b/PluginControlInterface/test/CMakeLists.txt
@@ -46,11 +46,30 @@ INCLUDE_DIRECTORIES(
file(GLOB CONTROL_RECEIVER_PLUGIN_INTERFACE_SRCS_CXX
"../../AudioManagerDaemon/src/CAmSocketHandler.cpp"
- "../../AudioManagerDaemon/src/CAmDltWrapper.cpp"
+ "../../AudioManagerDaemon/src/CAmDltWrapper.cpp"
+ "../../AudioManagerDaemon/src/CAmDatabaseObserver.cpp"
+ "../../AudioManagerDaemon/src/CAmCommandSender.cpp"
+ "../../AudioManagerDaemon/src/CAmTelnetServer.cpp"
+ "../../AudioManagerDaemon/src/CAmTelnetMenuHelper.cpp"
+ "../../AudioManagerDaemon/src/CAmRoutingSender.cpp"
+ "../../AudioManagerDaemon/src/CAmRoutingReceiver.cpp"
+ "../../AudioManagerDaemon/src/CAmCommandReceiver.cpp"
+ "../../AudioManagerDaemon/src/CAmControlSender.cpp"
+ "../../AudioManagerDaemon/src/CAmControlReceiver.cpp"
+ "../../AudioManagerDaemon/src/CAmRouter.cpp"
"../src/IAmControlReceiverShadow.cpp"
"CAmControlReceiverShadowTest.cpp"
)
+IF(WITH_DATABASE_STORAGE)
+ SET (CONTROL_RECEIVER_PLUGIN_INTERFACE_SRCS_CXX
+ ${CONTROL_RECEIVER_PLUGIN_INTERFACE_SRCS_CXX}
+ "../../AudioManagerDaemon/src/CAmDatabaseHandlerSQLite.cpp")
+ELSE(WITH_DATABASE_STORAGE)
+ SET (CONTROL_RECEIVER_PLUGIN_INTERFACE_SRCS_CXX
+ ${CONTROL_RECEIVER_PLUGIN_INTERFACE_SRCS_CXX}
+ "../../AudioManagerDaemon/src/CAmDatabaseHandlerMap.cpp")
+ENDIF(WITH_DATABASE_STORAGE)
ADD_EXECUTABLE(AmControlReceiverShadowTest ${CONTROL_RECEIVER_PLUGIN_INTERFACE_SRCS_CXX})