summaryrefslogtreecommitdiff
path: root/PluginCommandInterfaceDbus/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'PluginCommandInterfaceDbus/CMakeLists.txt')
-rw-r--r--PluginCommandInterfaceDbus/CMakeLists.txt7
1 files changed, 3 insertions, 4 deletions
diff --git a/PluginCommandInterfaceDbus/CMakeLists.txt b/PluginCommandInterfaceDbus/CMakeLists.txt
index 5a2877d..8926b33 100644
--- a/PluginCommandInterfaceDbus/CMakeLists.txt
+++ b/PluginCommandInterfaceDbus/CMakeLists.txt
@@ -16,7 +16,6 @@ set(AUDIO_INCLUDES_FOLDER ${CMAKE_SOURCE_DIR}/../includes)
set(DBUS_INCLUDES_FOLDER ${CMAKE_SOURCE_DIR}/../dbusIncludes)
set(INCLUDES_FOLDER ${CMAKE_SOURCE_DIR}/include)
-find_package (Threads)
FIND_PACKAGE(DBUS REQUIRED)
FIND_PACKAGE(PkgConfig)
pkg_check_modules(DLT REQUIRED automotive-dlt)
@@ -43,11 +42,11 @@ file(GLOB PLUGINDBUS_SRCS_CXX "src/*.cpp")
add_library(PluginCommandInterfaceDbus SHARED ${PLUGINDBUS_SRCS_CXX})
TARGET_LINK_LIBRARIES(PluginCommandInterfaceDbus
- ${DLT_LIBRARIES}
- ${DBUS_LIBRARY}
- ${CMAKE_THREAD_LIBS_INIT}
+ ${DLT_LIBRARIES}
+ ${DBUS_LIBRARY}
)
+add_subdirectory (test)
#add a target to generate API documentation with Doxygen
find_package(Doxygen)