summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7d63451..4dde49b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -23,7 +23,12 @@ execute_process(COMMAND git describe --tags WORKING_DIRECTORY ${CMAKE_CURRENT_SO
OUTPUT_STRIP_TRAILING_WHITESPACE)
IF (NOT DAEMONVERSION)
- SET( DAEMONVERSION "homebrew-${CMAKE_SOURCE_DIR}" )
+ #Can be changed via passing -DVERSION="XXX" to cmake
+ IF(NOT DEFINED VERSION)
+ SET( DAEMONVERSION "homebrew-${CMAKE_SOURCE_DIR}" )
+ ELSE (NOT DEFINED VERSION)
+ SET( DAEMONVERSION "${VERSION}" )
+ ENDIF(NOT DEFINED VERSION)
ELSE (NOT DAEMONVERSION)
STRING(REGEX REPLACE "(-)[^-]+$" "" DAEMONVERSION ${DAEMONVERSION})
STRING(REGEX REPLACE "-" "." DAEMONVERSION ${DAEMONVERSION})