summaryrefslogtreecommitdiff
path: root/AudioManagerDaemon/test/routingInterface/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'AudioManagerDaemon/test/routingInterface/CMakeLists.txt')
-rw-r--r--AudioManagerDaemon/test/routingInterface/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/AudioManagerDaemon/test/routingInterface/CMakeLists.txt b/AudioManagerDaemon/test/routingInterface/CMakeLists.txt
index 292065b..dc12a93 100644
--- a/AudioManagerDaemon/test/routingInterface/CMakeLists.txt
+++ b/AudioManagerDaemon/test/routingInterface/CMakeLists.txt
@@ -65,5 +65,14 @@ TARGET_LINK_LIBRARIES(routinginterfacetest
gmock
)
+INSTALL(TARGETS routinginterfacetest
+ DESTINATION "~/AudioManagerTest/"
+ PERMISSIONS OWNER_EXECUTE OWNER_WRITE OWNER_READ GROUP_EXECUTE GROUP_READ WORLD_EXECUTE WORLD_READ
+ COMPONENT tests
+)
+
+SET(ADD_DEPEND "audiomanager-bin" "sqlite3(>=3.6.22)" "dlt" "libdbus-1-3(>=1.2.16)" "libgtest-dev(>=1.6.0-1)" "google-mock" "libpthread-stubs0")
+set_property(GLOBAL APPEND PROPERTY tests_prop "${ADD_DEPEND}")
+