summaryrefslogtreecommitdiff
path: root/AudioManagerDaemon/test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'AudioManagerDaemon/test/CMakeLists.txt')
-rw-r--r--AudioManagerDaemon/test/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/AudioManagerDaemon/test/CMakeLists.txt b/AudioManagerDaemon/test/CMakeLists.txt
index b8ea4a7..af9f6cd 100644
--- a/AudioManagerDaemon/test/CMakeLists.txt
+++ b/AudioManagerDaemon/test/CMakeLists.txt
@@ -26,4 +26,7 @@ add_subdirectory (AmDatabaseHandlerTest)
add_subdirectory (AmRouterTest)
add_subdirectory (AmRoutingInterfaceTest)
add_subdirectory (AmSocketHandlerTest)
-add_subdirectory (AmTelnetServerTest)
+IF(WITH_TELNET)
+ add_subdirectory (AmTelnetServerTest)
+ENDIF(WITH_TELNET)
+