summaryrefslogtreecommitdiff
path: root/AudioManagerDaemon/test/AmRoutingInterfaceTest/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'AudioManagerDaemon/test/AmRoutingInterfaceTest/CMakeLists.txt')
-rw-r--r--AudioManagerDaemon/test/AmRoutingInterfaceTest/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/AudioManagerDaemon/test/AmRoutingInterfaceTest/CMakeLists.txt b/AudioManagerDaemon/test/AmRoutingInterfaceTest/CMakeLists.txt
index 7c19a4b..426ac7a 100644
--- a/AudioManagerDaemon/test/AmRoutingInterfaceTest/CMakeLists.txt
+++ b/AudioManagerDaemon/test/AmRoutingInterfaceTest/CMakeLists.txt
@@ -28,6 +28,13 @@ set (AM_LINK_LIBS
AudioManagerUtilities
rt)
+IF (WITH_CAPI_WRAPPER)
+ set (AM_LINK_LIBS
+ ${AM_LINK_LIBS}
+ -Wl,--as-needed CommonAPI
+ )
+ENDIF (WITH_CAPI_WRAPPER)
+
if(WITH_DLT)
pkg_check_modules(DLT REQUIRED automotive-dlt>=2.2.0)
set (AM_LINK_LIBS