summaryrefslogtreecommitdiff
path: root/AudioManagerDaemon/test/AmNodeStateCommunicatorDBusTest/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'AudioManagerDaemon/test/AmNodeStateCommunicatorDBusTest/CMakeLists.txt')
-rw-r--r--AudioManagerDaemon/test/AmNodeStateCommunicatorDBusTest/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/AudioManagerDaemon/test/AmNodeStateCommunicatorDBusTest/CMakeLists.txt b/AudioManagerDaemon/test/AmNodeStateCommunicatorDBusTest/CMakeLists.txt
index 4ecd421..242aff4 100644
--- a/AudioManagerDaemon/test/AmNodeStateCommunicatorDBusTest/CMakeLists.txt
+++ b/AudioManagerDaemon/test/AmNodeStateCommunicatorDBusTest/CMakeLists.txt
@@ -27,7 +27,9 @@ set(EXECUTABLE_OUTPUT_PATH ${TEST_EXECUTABLE_OUTPUT_PATH})
FIND_PACKAGE(Threads)
FIND_PACKAGE(DBUS REQUIRED)
FIND_PACKAGE(PkgConfig)
-pkg_check_modules(SQLITE REQUIRED sqlite3)
+IF(WITH_DATABASE_STORAGE)
+ pkg_check_modules(SQLITE REQUIRED sqlite3)
+ENDIF(WITH_DATABASE_STORAGE)
IF(WITH_DLT)