summaryrefslogtreecommitdiff
path: root/AudioManagerDaemon/test/AmNodeStateCommunicatorCAPITest/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'AudioManagerDaemon/test/AmNodeStateCommunicatorCAPITest/CMakeLists.txt')
-rw-r--r--AudioManagerDaemon/test/AmNodeStateCommunicatorCAPITest/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/AudioManagerDaemon/test/AmNodeStateCommunicatorCAPITest/CMakeLists.txt b/AudioManagerDaemon/test/AmNodeStateCommunicatorCAPITest/CMakeLists.txt
index 4817c24..862f3fc 100644
--- a/AudioManagerDaemon/test/AmNodeStateCommunicatorCAPITest/CMakeLists.txt
+++ b/AudioManagerDaemon/test/AmNodeStateCommunicatorCAPITest/CMakeLists.txt
@@ -22,7 +22,7 @@ PROJECT(AmNodeStateCommunicatorCAPITest)
set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -g -DUNIT_TEST=1")
set(STD_INCLUDE_DIRS "/usr/include")
-SET(COMMON_API_SRC_GEN "../../src-gen/")
+
set(EXECUTABLE_OUTPUT_PATH ${TEST_EXECUTABLE_OUTPUT_PATH})
FIND_PACKAGE(Threads)
@@ -32,6 +32,10 @@ pkg_check_modules(SQLITE REQUIRED sqlite3)
FIND_PACKAGE(CommonAPI REQUIRED)
FIND_PACKAGE(CommonAPI_DBus REQUIRED)
+
+#grab the parent source gen folder, instead of making a copy for the tests
+FILE(GLOB_RECURSE COMMON_API_GEN_SOURCES "../../src-gen/*.cpp")
+
IF(WITH_DLT)
pkg_check_modules(DLT REQUIRED automotive-dlt>=2.2.0)
ENDIF(WITH_DLT)