summaryrefslogtreecommitdiff
path: root/AudioManagerDaemon/test/AmMapHandlerTest/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'AudioManagerDaemon/test/AmMapHandlerTest/CMakeLists.txt')
-rw-r--r--AudioManagerDaemon/test/AmMapHandlerTest/CMakeLists.txt92
1 files changed, 92 insertions, 0 deletions
diff --git a/AudioManagerDaemon/test/AmMapHandlerTest/CMakeLists.txt b/AudioManagerDaemon/test/AmMapHandlerTest/CMakeLists.txt
new file mode 100644
index 0000000..aa00640
--- /dev/null
+++ b/AudioManagerDaemon/test/AmMapHandlerTest/CMakeLists.txt
@@ -0,0 +1,92 @@
+# Copyright (C) 2012, BMW AG
+#
+# This file is part of GENIVI Project AudioManager.
+#
+# Contributions are licensed to the GENIVI Alliance under one or more
+# Contribution License Agreements.
+#
+# copyright
+# This Source Code Form is subject to the terms of the
+# Mozilla Public License, v. 2.0. If a copy of the MPL was not distributed with
+# this file, You can obtain one at http://mozilla.org/MPL/2.0/.
+#
+# author Christian Mueller, christian.ei.mueller@bmw.de BMW 2011,2012
+#
+# For further information see http://www.genivi.org/.
+#
+
+cmake_minimum_required(VERSION 2.6)
+
+PROJECT(AmMapHandlerTest)
+
+set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -g -DUNIT_TEST=1 -DDLT_CONTEXT=AudioManager")
+
+
+FIND_PACKAGE(PkgConfig)
+#pkg_check_modules(SQLITE REQUIRED sqlite3)
+
+IF(WITH_DLT)
+ pkg_check_modules(DLT REQUIRED automotive-dlt>=2.2.0)
+ENDIF(WITH_DLT)
+
+INCLUDE_DIRECTORIES(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${AUDIO_INCLUDE_FOLDER}
+ ${DBUS_ARCH_INCLUDE_DIR}
+ ${DBUS_INCLUDE_FOLDER}
+ ${CMAKE_SOURCE_DIR}
+ ${STD_INCLUDE_DIRS}
+ ${DLT_INCLUDE_DIRS}
+ ${DBUS_INCLUDE_DIR}
+ ${INCLUDE_FOLDER}
+ ${GOOGLE_TEST_INCLUDE_DIR}
+ ${GMOCK_INCLUDE_DIR}
+)
+
+file(GLOB DATABASE_SRCS_CXX
+ "../../src/CAmMapHandler.cpp"
+ "../../src/CAmDatabaseHandler.cpp"
+ "../../src/CAmDatabaseObserver.cpp"
+ "../../src/CAmCommandSender.cpp"
+ "../../src/CAmRoutingSender.cpp"
+ "../../src/CAmControlReceiver.cpp"
+ "../../src/CAmControlSender.cpp"
+ "../../src/CAmRouter.cpp"
+ "../../src/CAmDltWrapper.cpp"
+ "../../src/CAmSocketHandler.cpp"
+ "../../src/CAmCommandReceiver.cpp"
+ "../../src/CAmRoutingReceiver.cpp"
+ "../../src/CAmDbusWrapper.cpp"
+ "../CAmCommonFunctions.cpp"
+ "*.cpp"
+ )
+
+IF(WITH_NSM)
+ SET (DATABASE_SRCS_CXX
+ ${DATABASE_SRCS_CXX}
+ "../../src/CAmNodeStateCommunicator.cpp")
+ENDIF(WITH_NSM)
+
+ADD_EXECUTABLE( AmMapHandlerTest ${DATABASE_SRCS_CXX})
+
+TARGET_LINK_LIBRARIES( AmMapHandlerTest
+ ${SQLITE_LIBRARIES}
+ ${DLT_LIBRARIES}
+ ${DBUS_LIBRARY}
+ ${CMAKE_THREAD_LIBS_INIT}
+ ${CMAKE_DL_LIBS}
+ gtest
+ gmock
+)
+
+ADD_DEPENDENCIES(AmMapHandlerTest gtest gmock)
+
+INSTALL(TARGETS AmMapHandlerTest
+ DESTINATION "~/AudioManagerTest/"
+ PERMISSIONS OWNER_EXECUTE OWNER_WRITE OWNER_READ GROUP_EXECUTE GROUP_READ WORLD_EXECUTE WORLD_READ
+ COMPONENT tests
+)
+
+SET(ADD_DEPEND "audiomanager-bin" "dlt" "libdbus-1-3(>=1.2.16)" "libpthread-stubs0")
+set_property(GLOBAL APPEND PROPERTY tests_prop "${ADD_DEPEND}")
+