summaryrefslogtreecommitdiff
path: root/AudioManagerDaemon/test/AmMapHandlerTest/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'AudioManagerDaemon/test/AmMapHandlerTest/CMakeLists.txt')
-rw-r--r--AudioManagerDaemon/test/AmMapHandlerTest/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/AudioManagerDaemon/test/AmMapHandlerTest/CMakeLists.txt b/AudioManagerDaemon/test/AmMapHandlerTest/CMakeLists.txt
index 22bd598..760be6c 100644
--- a/AudioManagerDaemon/test/AmMapHandlerTest/CMakeLists.txt
+++ b/AudioManagerDaemon/test/AmMapHandlerTest/CMakeLists.txt
@@ -33,6 +33,13 @@ if(WITH_DLT)
${DLT_LIBRARIES})
endif(WITH_DLT)
+IF (WITH_CAPI_WRAPPER)
+ set (AM_LINK_LIBS
+ ${AM_LINK_LIBS}
+ -Wl,--as-needed CommonAPI
+ )
+ENDIF (WITH_CAPI_WRAPPER)
+
INCLUDE_DIRECTORIES(
${CMAKE_CURRENT_BINARY_DIR}
${AUDIO_INCLUDE_FOLDER}