summaryrefslogtreecommitdiff
path: root/AudioManagerDaemon/test/AmMapHandlerTest/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'AudioManagerDaemon/test/AmMapHandlerTest/CMakeLists.txt')
-rw-r--r--AudioManagerDaemon/test/AmMapHandlerTest/CMakeLists.txt5
1 files changed, 2 insertions, 3 deletions
diff --git a/AudioManagerDaemon/test/AmMapHandlerTest/CMakeLists.txt b/AudioManagerDaemon/test/AmMapHandlerTest/CMakeLists.txt
index b4555e1..22bd598 100644
--- a/AudioManagerDaemon/test/AmMapHandlerTest/CMakeLists.txt
+++ b/AudioManagerDaemon/test/AmMapHandlerTest/CMakeLists.txt
@@ -23,6 +23,7 @@ set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -g -DUNIT_TEST=1 -DDLT_CONTEXT=AudioMan
set (AM_LINK_LIBS
${CMAKE_DL_LIBS}
+ AudioManagerUtilities
rt)
if(WITH_DLT)
@@ -55,10 +56,8 @@ file(GLOB DATABASE_SRCS_CXX
"${AUDIOMANAGER_DAEMON_FOLDER}/src/CAmControlReceiver.cpp"
"${AUDIOMANAGER_DAEMON_FOLDER}/src/CAmControlSender.cpp"
"${AUDIOMANAGER_DAEMON_FOLDER}/src/CAmRouter.cpp"
- "${AUDIOMANAGER_UTILITIES_SRC}/CAmSocketHandler.cpp"
"${AUDIOMANAGER_DAEMON_FOLDER}/src/CAmCommandReceiver.cpp"
"${AUDIOMANAGER_DAEMON_FOLDER}/src/CAmRoutingReceiver.cpp"
- "${AUDIOMANAGER_UTILITIES_SRC}/CAmDltWrapper.cpp"
"../CAmCommonFunctions.cpp"
"CAmTestDatabaseObserver.cpp"
"*.cpp"
@@ -74,7 +73,7 @@ TARGET_LINK_LIBRARIES( AmMapHandlerTest
gmock
)
-ADD_DEPENDENCIES(AmMapHandlerTest gtest gmock)
+ADD_DEPENDENCIES(AmMapHandlerTest gtest gmock AudioManagerUtilities)
INSTALL(TARGETS AmMapHandlerTest
DESTINATION ${TEST_EXECUTABLE_INSTALL_PATH}