summaryrefslogtreecommitdiff
path: root/AudioManagerCore/test/AmTelnetServerTest/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'AudioManagerCore/test/AmTelnetServerTest/CMakeLists.txt')
-rw-r--r--AudioManagerCore/test/AmTelnetServerTest/CMakeLists.txt48
1 files changed, 0 insertions, 48 deletions
diff --git a/AudioManagerCore/test/AmTelnetServerTest/CMakeLists.txt b/AudioManagerCore/test/AmTelnetServerTest/CMakeLists.txt
deleted file mode 100644
index 746edb5..0000000
--- a/AudioManagerCore/test/AmTelnetServerTest/CMakeLists.txt
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright (C) 2012, BMW AG
-#
-# This file is part of GENIVI Project AudioManager.
-#
-# Contributions are licensed to the GENIVI Alliance under one or more
-# Contribution License Agreements.
-#
-# copyright
-# This Source Code Form is subject to the terms of the
-# Mozilla Public License, v. 2.0. If a copy of the MPL was not distributed with
-# this file, You can obtain one at http://mozilla.org/MPL/2.0/.
-#
-# author Christian Linke, christian.linke@bmw.de BMW 2011,2012
-#
-# For further information see http://www.genivi.org/.
-#
-
-cmake_minimum_required(VERSION 3.0)
-
-PROJECT(AmTelnetServerTest LANGUAGES CXX VERSION ${DAEMONVERSION})
-
-INCLUDE_DIRECTORIES(
- ${AUDIOMANAGER_CORE_INCLUDE}
- ${GMOCK_INCLUDE_DIRS}
- ${GTEST_INCLUDE_DIRS})
-
-file(GLOB TELNET_SRCS_CXX
- "*.cpp"
-)
-
-ADD_EXECUTABLE(AmTelnetServerTest ${TELNET_SRCS_CXX})
-
-TARGET_LINK_LIBRARIES(AmTelnetServerTest
- ${GTEST_LIBRARIES}
- ${GMOCK_LIBRARIES}
- AudioManagerCore
-)
-#add_test(AmTelnetServerTest AmTelnetServerTest)
-
-ADD_DEPENDENCIES(AmTelnetServerTest AudioManagerCore)
-
-INSTALL(TARGETS AmTelnetServerTest
- DESTINATION ${TEST_EXECUTABLE_INSTALL_PATH}
- PERMISSIONS OWNER_EXECUTE OWNER_WRITE OWNER_READ GROUP_EXECUTE GROUP_READ WORLD_EXECUTE WORLD_READ
- COMPONENT tests
-)
-
-