summaryrefslogtreecommitdiff
path: root/tclap-1.2.1/configure.in
diff options
context:
space:
mode:
authorChristian Linke <christian.linke@bmw.de>2015-04-15 19:05:53 +0200
committerChristian Linke <christian.linke@bmw.de>2015-04-15 19:05:53 +0200
commit64944e1fa72f346f1161da60c033de2e10513bea (patch)
tree12f668bf4024365311dd46bd3dc904f57e00f8fa /tclap-1.2.1/configure.in
parenta0b06e2a9b466cfcc6f6810a66d9522a56872cbb (diff)
downloadaudiomanager-64944e1fa72f346f1161da60c033de2e10513bea.tar.gz
* implemend command line options for plugins. rework of command line
* add tclap as template library * implement bug 344 Signed-off-by: Christian Linke <christian.linke@bmw.de>
Diffstat (limited to 'tclap-1.2.1/configure.in')
-rw-r--r--tclap-1.2.1/configure.in31
1 files changed, 31 insertions, 0 deletions
diff --git a/tclap-1.2.1/configure.in b/tclap-1.2.1/configure.in
new file mode 100644
index 0000000..66b3dab
--- /dev/null
+++ b/tclap-1.2.1/configure.in
@@ -0,0 +1,31 @@
+AC_INIT(Makefile.am)
+#AC_PREREQ(2.50)
+AC_CONFIG_AUX_DIR(config)
+AM_CONFIG_HEADER(config/config.h)
+AM_INIT_AUTOMAKE(tclap,1.2.1)
+AC_PROG_CXX
+AC_CXX_HAVE_SSTREAM
+AC_CXX_HAVE_STRSTREAM
+AC_CXX_HAVE_LONG_LONG
+AC_CHECK_PROG(DOT,dot,YES,NO)
+AC_PROG_RANLIB
+AC_PROG_INSTALL
+BB_ENABLE_DOXYGEN
+
+HAVE_WARN_EFFECTIVE_CXX
+CXXFLAGS="$CXXFLAGS $WARN_EFFECTIVE_CXX"
+
+AM_CONDITIONAL([HAVE_GNU_COMPILERS], [test x$ac_cv_cxx_compiler_gnu = xyes])
+
+AC_OUTPUT([ Makefile \
+ tclap.pc \
+ examples/Makefile \
+ include/Makefile \
+ include/tclap/Makefile \
+ config/Makefile \
+ docs/Makefile \
+ docs/Doxyfile \
+ msc/Makefile \
+ msc/examples/Makefile \
+ tests/Makefile], \
+ [chmod a+x $ac_top_srcdir/tests/*.sh])