summaryrefslogtreecommitdiff
path: root/googleMock/CMakeLists.txt
diff options
context:
space:
mode:
authorchristian linke <christian.linke@bmw.de>2012-12-17 16:15:11 +0100
committerchristian linke <christian.linke@bmw.de>2012-12-17 16:15:11 +0100
commit54c5e965fe8f9a53a78834028fd65c792493da2b (patch)
tree560d7b1209e6a8d4798de9568e4b4a947c2ab42a /googleMock/CMakeLists.txt
parent215e8a72dc81e8a86dd5b3a8ca40fd2c7c6a0b9c (diff)
downloadaudiomanager-54c5e965fe8f9a53a78834028fd65c792493da2b.tar.gz
* added new interfaces & nsm support + nsm tests + fixed some unit tests + fixed rundown
Signed-off-by: christian linke <christian.linke@bmw.de>
Diffstat (limited to 'googleMock/CMakeLists.txt')
-rw-r--r--googleMock/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/googleMock/CMakeLists.txt b/googleMock/CMakeLists.txt
index 061c2fc..2db2f96 100644
--- a/googleMock/CMakeLists.txt
+++ b/googleMock/CMakeLists.txt
@@ -7,6 +7,8 @@
# BUILD_SHARED_LIBS is a standard CMake variable, but we declare it here to
# make it prominent in the GUI.
+set (CMAKE_CXX_FLAGS "-std=gnu++0x -D_GNU_SOURCE -Wno-variadic-macros")
+
option(BUILD_SHARED_LIBS "Build shared libraries (DLLs)." OFF)
# Forces BUILD_SHARED_LIBS to OFF as Google Mock currently does not support