summaryrefslogtreecommitdiff
path: root/PluginHookStandard/CMakeLists.txt
diff options
context:
space:
mode:
authorblacky <blacky@kiwi.(none)>2011-07-15 20:25:22 +0200
committerblacky <blacky@kiwi.(none)>2011-07-15 20:25:22 +0200
commit6d7c17a9ab1bccbf0bc656c87818338de28f408d (patch)
treeb96d2adb2bf8271242cedad216856207c795ea92 /PluginHookStandard/CMakeLists.txt
parent8da33c909cfce7370ef8e53acb2e3a00464edf37 (diff)
downloadaudiomanager-6d7c17a9ab1bccbf0bc656c87818338de28f408d.tar.gz
- first attempt to remove QT
- this compiles but does not provide the same functionality - hookplugin compiles - other plugins do not
Diffstat (limited to 'PluginHookStandard/CMakeLists.txt')
-rw-r--r--PluginHookStandard/CMakeLists.txt45
1 files changed, 45 insertions, 0 deletions
diff --git a/PluginHookStandard/CMakeLists.txt b/PluginHookStandard/CMakeLists.txt
new file mode 100644
index 0000000..d2e5d22
--- /dev/null
+++ b/PluginHookStandard/CMakeLists.txt
@@ -0,0 +1,45 @@
+cmake_minimum_required(VERSION 2.6)
+
+PROJECT(PluginHookStandard)
+
+set(CMAKE_CXX_FLAGS "-g -pipe -fPIC -Wall -W -D_REENTRANT")
+
+set(STD_INCLUDE_DIRS "/usr/include")
+set(EXECUTABLE_OUTPUT_PATH ../../bin/)
+set(LIBRARY_OUTPUT_PATH ../plugins)
+set(DOC_OUTPUT_PATH ${CMAKE_SOURCE_DIR}/../doc/PluginHookStandard)
+set(DOCUMENT $ENV{gendoc})
+
+cmake_policy(SET CMP0015 NEW)
+
+file(MAKE_DIRECTORY ${DOC_OUTPUT_PATH})
+
+INCLUDE_DIRECTORIES(
+ ${CMAKE_SOURCE_DIR}
+ ${STD_INCLUDE_DIRS}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ../AudioManagerDaemon
+)
+
+# all source files go here
+SET(PLUGIN_STANDARD_HOOKS_SRCS_CXX
+ StandardHook.cpp
+)
+
+add_library(PluginHookStandard SHARED ${PLUGIN_STANDARD_HOOKS_SRCS_CXX})
+add_library(PluginHookStandard ${PLUGIN_STANDARD_HOOKS_SRCS_CXX})
+
+TARGET_LINK_LIBRARIES(PluginHookStandard
+)
+
+#add a target to generate API documentation with Doxygen
+find_package(Doxygen)
+if(DOXYGEN_FOUND)
+if(DOCUMENT)
+ configure_file(Doxyfile.in ${PROJECT_BINARY_DIR}/Doxyfile @ONLY IMMEDIATE)
+ add_custom_target (Docs ALL
+ COMMAND ${DOXYGEN_EXECUTABLE} ${PROJECT_BINARY_DIR}/Doxyfile WORKING_DIRECTORY ${DOC_OUTPUT_PATH}
+ SOURCES ${PROJECT_BINARY_DIR}/Doxyfile)
+endif(DOCUMENT)
+endif(DOXYGEN_FOUND)
+