summaryrefslogtreecommitdiff
path: root/PluginCommandInterfaceDbus/test/CMakeLists.txt
diff options
context:
space:
mode:
authorchristian mueller <christian.ei.mueller@bmw.de>2012-02-29 13:27:27 +0100
committerchristian mueller <christian.ei.mueller@bmw.de>2012-02-29 13:27:27 +0100
commitd3ccf97331935b181041394b80be20dca282ea71 (patch)
treef85e7b649c8a6d58c11e9728b2442cdcff53826d /PluginCommandInterfaceDbus/test/CMakeLists.txt
parentaa93713377d28a8ce7821466ef828f79a18e982d (diff)
downloadaudiomanager-d3ccf97331935b181041394b80be20dca282ea71.tar.gz
* [ performance] for classes that do not need to be derived from, removed virtual desctructor
* implemented confirmation of routing ready in RoutingReceiver * [Sockethandler] automatically set gDispatchDone to 0 when starting mainloop * fixed unit text to work with latest changes (expect Dbus command interface) * [GAM-4] added way to do synchronous calling on interfaces with the help of CAmSerializer.h * reworked AsyncRoutingPlugin to work with CAmSerializer.h * reworked AsyncRoutingPlugin to register elemtes in thread using CAmSerializer.h * reworked AsncPlugin Tests to work with remodelled Plugin
Diffstat (limited to 'PluginCommandInterfaceDbus/test/CMakeLists.txt')
-rw-r--r--PluginCommandInterfaceDbus/test/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/PluginCommandInterfaceDbus/test/CMakeLists.txt b/PluginCommandInterfaceDbus/test/CMakeLists.txt
index 0c33420..8745af8 100644
--- a/PluginCommandInterfaceDbus/test/CMakeLists.txt
+++ b/PluginCommandInterfaceDbus/test/CMakeLists.txt
@@ -69,6 +69,8 @@ file(GLOB DBUS_SIGNAL_INTERFACE_SRCS_CXX
"../../AudioManagerDaemon/src/CommandSender.cpp"
"../../AudioManagerDaemon/src/SocketHandler.cpp"
"../../AudioManagerDaemon/src/DLTWrapper.cpp"
+ "../../AudioManagerDaemon/src/DatabaseHandler.cpp"
+ "../../AudioManagerDaemon/src/ControlSender.cpp"
"../src/*.cpp"
"dbuscommaninterfacesignalsTest.cpp"
"DbusCommandInterfaceBackdoor.cpp"