summaryrefslogtreecommitdiff
path: root/PluginCommandInterfaceDbus/CMakeLists.txt
diff options
context:
space:
mode:
authorChristian Mueller <christian@lmuc329619u.(none)>2011-12-16 12:29:27 +0100
committerChristian Mueller <christian@lmuc329619u.(none)>2011-12-16 12:29:27 +0100
commit392d090c63dcb03df8a044abbc6cc84807e341e5 (patch)
tree10ea0610a5a6d0e8c9ebbe01b6433fcd1c754ebf /PluginCommandInterfaceDbus/CMakeLists.txt
parent281cb0d875832bb56c82bad3516fc4021f8be4b0 (diff)
downloadaudiomanager-392d090c63dcb03df8a044abbc6cc84807e341e5.tar.gz
changes to make controlSender compile & loadable
Diffstat (limited to 'PluginCommandInterfaceDbus/CMakeLists.txt')
-rw-r--r--PluginCommandInterfaceDbus/CMakeLists.txt7
1 files changed, 3 insertions, 4 deletions
diff --git a/PluginCommandInterfaceDbus/CMakeLists.txt b/PluginCommandInterfaceDbus/CMakeLists.txt
index 5a2877d..8926b33 100644
--- a/PluginCommandInterfaceDbus/CMakeLists.txt
+++ b/PluginCommandInterfaceDbus/CMakeLists.txt
@@ -16,7 +16,6 @@ set(AUDIO_INCLUDES_FOLDER ${CMAKE_SOURCE_DIR}/../includes)
set(DBUS_INCLUDES_FOLDER ${CMAKE_SOURCE_DIR}/../dbusIncludes)
set(INCLUDES_FOLDER ${CMAKE_SOURCE_DIR}/include)
-find_package (Threads)
FIND_PACKAGE(DBUS REQUIRED)
FIND_PACKAGE(PkgConfig)
pkg_check_modules(DLT REQUIRED automotive-dlt)
@@ -43,11 +42,11 @@ file(GLOB PLUGINDBUS_SRCS_CXX "src/*.cpp")
add_library(PluginCommandInterfaceDbus SHARED ${PLUGINDBUS_SRCS_CXX})
TARGET_LINK_LIBRARIES(PluginCommandInterfaceDbus
- ${DLT_LIBRARIES}
- ${DBUS_LIBRARY}
- ${CMAKE_THREAD_LIBS_INIT}
+ ${DLT_LIBRARIES}
+ ${DBUS_LIBRARY}
)
+add_subdirectory (test)
#add a target to generate API documentation with Doxygen
find_package(Doxygen)