summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAleksandar Donchev <Aleksander.Donchev@partner.bmw.de>2017-05-19 11:55:01 +0200
committerJacqueline Molz <Jacqueline.Molz@bmw.de>2017-07-10 12:35:05 +0200
commitbe63615585049aa4045f13e91291d64b0a9ed5a3 (patch)
tree9baabfbf751e85d0980f74e55e8332f6e20c379f /CMakeLists.txt
parent375dc7b81795da9bfd8372f629d7fcef704a6d58 (diff)
downloadaudiomanager-be63615585049aa4045f13e91291d64b0a9ed5a3.tar.gz
The primary signals SIGINT and SIGQUIT are handled on top level in
contrast to secondary signals SIGHUP, SIGTERM, SIGCHLD, which are handled in the SocketHandler. Signed-off-by: Christian Linke <christian.linke@bmw.de> Change-Id: I8c5d3c436ac9fcd61c76a26145c731b427cab1e6
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b89daa1..5c70c61 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -141,6 +141,7 @@ if(WITH_TESTS)
#check if we can find the google stuff
pkg_check_modules (GTEST "gtest >= 1.6.0")
pkg_check_modules (GMOCK "gmock >= 1.6.0")
+ find_package (Threads)
if (NOT("${GTEST_FOUND}" AND "${GMOCK_FOUND}"))
message (STATUS "Building and installing with shipped sources")
add_subdirectory(googleMock)