summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJens Lorenz <jlorenz@de.adit-jv.com>2017-03-14 08:58:49 +0100
committerJens Lorenz <jlorenz@de.adit-jv.com>2017-04-11 21:36:34 +0200
commit698bf42333c7f75873c455cc1321ee722b2771b2 (patch)
tree8fd725f4c80dc9931c99caee4663a3e571146e01 /CMakeLists.txt
parentb3075389aa61c019fdb5d904abab84532f178250 (diff)
downloadaudiomanager-698bf42333c7f75873c455cc1321ee722b2771b2.tar.gz
AMCore: Start dynamic resources range from DYNAMIC_ID_BOUNDARY
Currently the DYNAMIC_ID_BOUNDARY value is not part of static nor dynamic section. Every element like a source which is registered with this value is not addressable. Signed-off-by: Jens Lorenz <jlorenz@de.adit-jv.com>
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4655a23..33433ee 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -67,8 +67,8 @@ set(DBUS_SERVICE_PREFIX "org.genivi.audiomanager"
set(DBUS_SERVICE_OBJECT_PATH "/org/genivi/audiomanager"
CACHE PROPERTY "The service object path of the AM - only changable for legacy dbus")
-set(DYNAMIC_ID_BOUNDARY 100
- CACHE INTEGER "The ID boundary between static and dynamic ID ranges")
+set(DYNAMIC_ID_BOUNDARY 101
+ CACHE INTEGER "The ID boundary defines the starting point of the dynamic ID range")
set(LIB_INSTALL_SUFFIX "audiomanager"
CACHE STRINGS "The suffix used for installation of the plugins")