summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJens Lorenz <jlorenz@de.adit-jv.com>2018-02-12 17:45:56 +0100
committerJens Lorenz <jlorenz@de.adit-jv.com>2018-02-13 11:05:45 +0100
commit5b8411277e44e92eea3b8e9469af003415c02a6f (patch)
tree1ef22847112e596d79de199ce5de1c500c86f8cd /CMakeLists.txt
parenta4e8cdcef0ebf57b23ea6676a54c39e256e906eb (diff)
downloadaudiomanager-5b8411277e44e92eea3b8e9469af003415c02a6f.tar.gz
CMake: Implement VCS agnostic versioning
Versioning should not strictly depend on Version Control System (e.g. git). Best approach is to have a dedicated VERSION file exposing with format <Major>.<Minor>.<Revision>. Target is that maintainer will manually release the version once patches/fixes are merged e.g. to a stabilization branch. In order to have an OEM specific meta information exposed with the version information EXTRAVERSIONINFO can be specified by CMAKE flag. Signed-off-by: Guerra Mattia <mguerra@de.adit-jv.com>
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 38d1a68..7e3bddb 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -24,6 +24,10 @@ include ( MacroInterfaceVersions )
project(AudioManager LANGUAGES C CXX VERSION ${DAEMONVERSION})
+IF (NOT EXTRAVERSIONINFO)
+ ADD_DEFINITIONS(-DEXTRAVERSIONINFO="")
+ENDIF (NOT EXTRAVERSIONINFO)
+
include ( CMakeDependentOption )
include ( CMakePackageConfigHelpers )
include ( GNUInstallDirs )