summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGuerra Mattia <mguerra@de.adit-jv.com>2017-05-19 14:39:35 +0200
committerJens Lorenz <jlorenz@de.adit-jv.com>2017-09-29 11:42:01 +0200
commit4bfe4632624bc3ee13fa85f0ffdc23d7618e65e3 (patch)
tree433c85e19c220587e9ae105bcda31c15fbb3bca5 /CMakeLists.txt
parent3e9f7977dc599b6a91e875c8239480f212a4cd3a (diff)
downloadaudiomanager-4bfe4632624bc3ee13fa85f0ffdc23d7618e65e3.tar.gz
CMake: Use GNUInstalDirs destinations
Replace hardcoded "lib" with ${CMAKE_INSTALL_LIBDIR} to provide multilib support. Signed-off-by: Frederik Sdun <frederik_sdun@mentor.com> Signed-off-by: Mikhail Durnev <mikhail_durnev@mentor.com>
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5c70c61..9f3bbe7 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -76,13 +76,13 @@ set(DYNAMIC_ID_BOUNDARY 101
set(LIB_INSTALL_SUFFIX "audiomanager"
CACHE STRINGS "The suffix used for installation of the plugins")
-set(TEST_EXECUTABLE_INSTALL_PATH ${CMAKE_INSTALL_PREFIX}/bin
+set(TEST_EXECUTABLE_INSTALL_PATH ${CMAKE_INSTALL_BINDIR}
CACHE STRINGS "The test binaries will be installed here")
set(DOC_OUTPUT_PATH ${CMAKE_CURRENT_BINARY_DIR}/doc/AudioManager
CACHE STRINGS "The doxygen documentation will be placed here")
-set(AM_SHARE_FOLDER ${CMAKE_INSTALL_PREFIX}/share/audiomanager
+set(AM_SHARE_FOLDER ${CMAKE_INSTALL_DATAROOTDIR}/audiomanager
CACHE STRINGS "The share folder for the AM. Some DBus xmls will be placed here and so on")
set(AM_MAP_CAPACITY 10