summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChristian Linke <Christian.Linke@bmw.de>2016-03-01 23:36:34 -0800
committerChristian Linke <Christian.Linke@bmw.de>2016-03-01 23:36:34 -0800
commit3b7254a3c3bacef46afebd36f027a16c2845ee11 (patch)
tree5c7e957ef3597e1c082ae8593b18e88cdfb845e5 /CMakeLists.txt
parent6dfc4665743e61d1e4dbed634c41265dbbdeba77 (diff)
downloadaudiomanager-3b7254a3c3bacef46afebd36f027a16c2845ee11.tar.gz
Fix issues with cmake cross build and yocto
Signed-off-by: Christian Linke <Christian.Linke@bmw.de>
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f8d0dc3..ac2c043 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -126,10 +126,13 @@ if(NOT DEFINED CONTROLLER_PLUGIN_DIR)
endif(NOT DEFINED CONTROLLER_PLUGIN_DIR)
##global build flags set(CPACK_RPM_COMPONENT_INSTALL ON)
-set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=gnu++11 -pedantic -rdynamic -Wno-variadic-macros")
+set (AUDIOMANAGER_CMAKE_CXX_FLAGS "-std=gnu++11 -pedantic -rdynamic -Wno-variadic-macros")
+
+set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${AUDIOMANAGER_CMAKE_CXX_FLAGS}")
set (CMAKE_CXX_FLAGS_DEBUG "${CMAKE_CXX_FLAGS} -g -DDEBUG")
set (CMAKE_CXX_FLAGS_RELEASE "${CMAKE_CXX_FLAGS} -O2 -DNDEBUG")
+
if(WITH_TESTS)
#check if we can find the google stuff
pkg_check_modules (GTEST "gtest >= 1.6.0")