summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAleksandar Donchev <Aleksander.Donchev@partner.bmw.de>2013-11-25 15:06:13 +0100
committerChristian Linke <christian.linke@bmw.de>2014-03-28 16:47:37 +0100
commit4ee76fe25e635fe8d1daa49f7af3ce4339048be9 (patch)
tree36684071d59daf1d4215b4b49b79517e20fdf466 /CMakeLists.txt
parentd0db55e3e2a37119d10b6db6092480fa544fd88b (diff)
downloadaudiomanager-4ee76fe25e635fe8d1daa49f7af3ce4339048be9.tar.gz
* Cmake scripts adopted for cross-compilation
Signed-off-by: Christian Linke <christian.linke@bmw.de>
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index be807be..24baa47 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -39,9 +39,11 @@ message(STATUS "Build Version ${DAEMONVERSION}")
execute_process(COMMAND git log --pretty=short WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}
OUTPUT_FILE ${CMAKE_CURRENT_SOURCE_DIR}/CHANGELOG)
-
+
PROJECT(AudioManagerDeamon)
+message( STATUS "CMAKE_TOOLCHAIN_FILE='${CMAKE_TOOLCHAIN_FILE}'" )
+
FIND_PACKAGE(PkgConfig)
SET(WITH_ENABLED_IPC "CAPI" CACHE STRING "Disable 'NONE' / Enable Common-API 'CAPI' or Dbus 'DBUS' Support")
@@ -225,6 +227,7 @@ ENDIF(WITH_DOCUMENTATION)
set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -g -Wall -Wextra -std=gnu++0x -D_GNU_SOURCE -pedantic -Wno-variadic-macros -Wno-long-long")
#set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -g -Wall -Wextra -std=c++98 -D_GNU_SOURCE")
+
if(WITH_PLUGIN_COMMAND)
if(WITH_DBUS_WRAPPER)
add_subdirectory (PluginCommandInterfaceDbus)
@@ -248,6 +251,7 @@ endif(WITH_PLUGIN_CONTROL)
add_subdirectory (AudioManagerDaemon)
+
IF(EXISTS "${CMAKE_SOURCE_DIR}/ProjectSpecific/")
add_subdirectory (ProjectSpecific)
endif(EXISTS "${CMAKE_SOURCE_DIR}/ProjectSpecific/")