summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorchristian mueller <christian.ei.mueller@bmw.de>2012-04-11 13:19:56 +0200
committerchristian mueller <christian.ei.mueller@bmw.de>2012-05-24 13:40:22 +0200
commit31402357e30a0088a4ce3557b20401e76c420cd5 (patch)
treeb23b3940b2db62b9bd27d6dcf60aa7f174ed674e /CMakeLists.txt
parent612ccfda8de3ea61978606fed65eab0fd4a92f25 (diff)
downloadaudiomanager-31402357e30a0088a4ce3557b20401e76c420cd5.tar.gz
* [GAM-40] build audiomanager with a version but without git
* adopted readme Signed-off-by: christian mueller <christian.ei.mueller@bmw.de>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7d63451..4dde49b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -23,7 +23,12 @@ execute_process(COMMAND git describe --tags WORKING_DIRECTORY ${CMAKE_CURRENT_SO
OUTPUT_STRIP_TRAILING_WHITESPACE)
IF (NOT DAEMONVERSION)
- SET( DAEMONVERSION "homebrew-${CMAKE_SOURCE_DIR}" )
+ #Can be changed via passing -DVERSION="XXX" to cmake
+ IF(NOT DEFINED VERSION)
+ SET( DAEMONVERSION "homebrew-${CMAKE_SOURCE_DIR}" )
+ ELSE (NOT DEFINED VERSION)
+ SET( DAEMONVERSION "${VERSION}" )
+ ENDIF(NOT DEFINED VERSION)
ELSE (NOT DAEMONVERSION)
STRING(REGEX REPLACE "(-)[^-]+$" "" DAEMONVERSION ${DAEMONVERSION})
STRING(REGEX REPLACE "-" "." DAEMONVERSION ${DAEMONVERSION})