summaryrefslogtreecommitdiff
path: root/AudioManagerUtilities/test/CMakeLists.txt
diff options
context:
space:
mode:
authorMartin Koch <51775589+mkoch-aditg@users.noreply.github.com>2020-02-10 08:08:28 +0100
committerGitHub <noreply@github.com>2020-02-10 08:08:28 +0100
commitce23c6757e083040ce05c1ad758ba25caf98b44f (patch)
tree20c36aab9ca43ad651565bec2e7c8db6eee92a2b /AudioManagerUtilities/test/CMakeLists.txt
parent86963abab32af54f7fe1244a727d3340ddeb5450 (diff)
parent56b7b1883c354b78ab6cff5739ddd2f170603324 (diff)
downloadaudiomanager-ce23c6757e083040ce05c1ad758ba25caf98b44f.tar.gz
Merge pull request #48 from GENIVI/LoggingArchitecture
AM-Utils: Introduce new logging architecture, providing a common DLT-independant wrapper for the 3 logging channels (DLT, file and stdout)
Diffstat (limited to 'AudioManagerUtilities/test/CMakeLists.txt')
-rw-r--r--AudioManagerUtilities/test/CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/AudioManagerUtilities/test/CMakeLists.txt b/AudioManagerUtilities/test/CMakeLists.txt
index 414e199..74e56f9 100644
--- a/AudioManagerUtilities/test/CMakeLists.txt
+++ b/AudioManagerUtilities/test/CMakeLists.txt
@@ -1,2 +1,8 @@
-add_subdirectory (AmSocketHandlerTest)
+if (WITH_DLT)
+ # this test works only if Utilities are built with DLT support - skip otherwise
+ add_subdirectory (AmSocketHandlerTest)
+else (WITH_DLT)
+ message ( WARNING "CAmSocketHandlerTest requires DLT support - skipping ...")
+endif (WITH_DLT)
+
add_subdirectory (AmSerializerTest)