summaryrefslogtreecommitdiff
path: root/AudioManagerDaemon/test/CMakeLists.txt
diff options
context:
space:
mode:
authorAleksandar Donchev <aleksander.donchev@partner.bmw.de>2013-09-02 11:57:28 +0200
committerChristian Linke <Christian.Linke@bmw.de>2013-09-03 17:26:04 +0200
commita2edae5cee4254b933f42399edc0e092abd4f5cf (patch)
treeead58f525b947deed4b8c76ab9c89c80b5056227 /AudioManagerDaemon/test/CMakeLists.txt
parent7aee1baeea1777318932cc49a8eac18f194233cd (diff)
downloadaudiomanager-a2edae5cee4254b933f42399edc0e092abd4f5cf.tar.gz
*PluginCommandInterfaceCAPI, PluginRoutingInterfaceCAPI, NodeStateCommunicatorCAPI with unit tests first version.
Choosing between DBUS and Common-API via cmake. CommonAPI - legacy support for DBus properties (Set 1) Signed-off-by: Christian Linke <christian.linke@bmw.de> (cherry picked from commit ea96ef59e29466667c90b506426e2a5a9cdb82d2)
Diffstat (limited to 'AudioManagerDaemon/test/CMakeLists.txt')
-rw-r--r--AudioManagerDaemon/test/CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/AudioManagerDaemon/test/CMakeLists.txt b/AudioManagerDaemon/test/CMakeLists.txt
index 5eda5cb..e0ae651 100644
--- a/AudioManagerDaemon/test/CMakeLists.txt
+++ b/AudioManagerDaemon/test/CMakeLists.txt
@@ -27,8 +27,13 @@ add_subdirectory (AmRouterTest)
add_subdirectory (AmRouterMapTest)
add_subdirectory (AmRoutingInterfaceTest)
add_subdirectory (AmSocketHandlerTest)
+
IF(WITH_NSM)
- add_subdirectory (AmNodeStateCommunicatorTest)
+ IF(WITH_DBUS_WRAPPER)
+ add_subdirectory (AmNodeStateCommunicatorDBusTest)
+ ELSEIF(WITH_CAPI_WRAPPER)
+ add_subdirectory (AmNodeStateCommunicatorCAPITest)
+ ENDIF()
ENDIF(WITH_NSM)
IF(WITH_TELNET)