summaryrefslogtreecommitdiff
path: root/AudioManagerDaemon/test/AmNodeStateCommunicatorCAPITest/CMakeLists.txt
diff options
context:
space:
mode:
authorAleksandar Donchev <Aleksander.Donchev@partner.bmw.de>2014-02-12 14:57:34 +0100
committerChristian Linke <christian.linke@bmw.de>2014-03-28 16:48:02 +0100
commit0717ec147195b11fdf23f8326211b97b6ac9b283 (patch)
tree5d50dabaf8086ac17802fc6c8c4872b783065095 /AudioManagerDaemon/test/AmNodeStateCommunicatorCAPITest/CMakeLists.txt
parent0360f3d41beb1f66bfbfddf16a9727f4368b75f5 (diff)
downloadaudiomanager-0717ec147195b11fdf23f8326211b97b6ac9b283.tar.gz
* Support for automatically generation of common-api sources. Cmake macros adopted to support the common-api generator.
Signed-off-by: Christian Linke <christian.linke@bmw.de>
Diffstat (limited to 'AudioManagerDaemon/test/AmNodeStateCommunicatorCAPITest/CMakeLists.txt')
-rw-r--r--AudioManagerDaemon/test/AmNodeStateCommunicatorCAPITest/CMakeLists.txt8
1 files changed, 1 insertions, 7 deletions
diff --git a/AudioManagerDaemon/test/AmNodeStateCommunicatorCAPITest/CMakeLists.txt b/AudioManagerDaemon/test/AmNodeStateCommunicatorCAPITest/CMakeLists.txt
index 862f3fc..d317b62 100644
--- a/AudioManagerDaemon/test/AmNodeStateCommunicatorCAPITest/CMakeLists.txt
+++ b/AudioManagerDaemon/test/AmNodeStateCommunicatorCAPITest/CMakeLists.txt
@@ -27,14 +27,8 @@ set(EXECUTABLE_OUTPUT_PATH ${TEST_EXECUTABLE_OUTPUT_PATH})
FIND_PACKAGE(Threads)
FIND_PACKAGE(PkgConfig)
-pkg_check_modules(SQLITE REQUIRED sqlite3)
-
FIND_PACKAGE(CommonAPI REQUIRED)
-FIND_PACKAGE(CommonAPI_DBus REQUIRED)
-
-
-#grab the parent source gen folder, instead of making a copy for the tests
-FILE(GLOB_RECURSE COMMON_API_GEN_SOURCES "../../src-gen/*.cpp")
+pkg_check_modules(SQLITE REQUIRED sqlite3)
IF(WITH_DLT)
pkg_check_modules(DLT REQUIRED automotive-dlt>=2.2.0)