summaryrefslogtreecommitdiff
path: root/AudioManagerDaemon/CMakeLists.txt
diff options
context:
space:
mode:
authorChristian Linke <christian.linke@bmw.de>2014-11-03 08:44:18 +0100
committerChristian Linke <christian.linke@bmw.de>2014-11-03 18:37:32 +0100
commit6737f225604b116185225c6647a2c59f1b03ae24 (patch)
treea7de365e6598fb679ef06669f29bf9da72c0b4bc /AudioManagerDaemon/CMakeLists.txt
parentbfd958452e5005a8a7a484afdfa3b1065e1e0c82 (diff)
downloadaudiomanager-6737f225604b116185225c6647a2c59f1b03ae24.tar.gz
* Make Audiomanager compile without sqlite
Signed-off-by: Christian Linke <christian.linke@bmw.de>
Diffstat (limited to 'AudioManagerDaemon/CMakeLists.txt')
-rw-r--r--AudioManagerDaemon/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/AudioManagerDaemon/CMakeLists.txt b/AudioManagerDaemon/CMakeLists.txt
index 37842a1..e263aea 100644
--- a/AudioManagerDaemon/CMakeLists.txt
+++ b/AudioManagerDaemon/CMakeLists.txt
@@ -157,6 +157,7 @@ INCLUDE_DIRECTORIES(
IF(WITH_CAPI_WRAPPER)
+IF(WITH_NSM)
# Find the common-api sources.
# The sources can be placed in the build directory (DESTINATION) or in the source tree (ALT_DESTINATION).
# The ALT_DESTINATION is used as fall back if the DESTINATION directory dosen't contain the sources or you just don't want to use the generator.
@@ -166,6 +167,7 @@ COMMON_API_GENERATE_SOUCRES(TARGET COMMON_API
DESTINATION src-gen # a relative path to the build directory or an absolute path
ALT_DESTINATION ${CMAKE_CURRENT_SOURCE_DIR}/src-gen # an alternative relative/absolute path with common-api sources, usually in the source tree
DBUS)
+ENDIF(WITH_NSM)
INCLUDE_DIRECTORIES(${INCLUDE_DIRECTORIES}
${COMMON_API_INCLUDE_DIRS}