summaryrefslogtreecommitdiff
path: root/tests/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build20
1 files changed, 20 insertions, 0 deletions
diff --git a/tests/meson.build b/tests/meson.build
new file mode 100644
index 0000000..1fbb992
--- /dev/null
+++ b/tests/meson.build
@@ -0,0 +1,20 @@
+tests = [
+ 'testdocument',
+ 'testrole',
+ 'testrelation',
+ 'teststateset',
+ 'testvalue',
+]
+
+foreach t: tests
+ bin = executable(t, t + '.c',
+ dependencies: libatk_dep,
+ include_directories: root_inc,
+ c_args: common_cflags + [
+ '-DG_DISABLE_DEPRECATED',
+ ])
+ test(t, bin, env: [
+ 'G_TEST_SRCDIR=@0@'.format(meson.current_source_dir()),
+ 'G_TEST_BUILDDIR=@0@'.format(meson.current_build_dir()),
+ ])
+endforeach