summaryrefslogtreecommitdiff
path: root/build/win32/vs9/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'build/win32/vs9/Makefile.am')
-rw-r--r--build/win32/vs9/Makefile.am18
1 files changed, 10 insertions, 8 deletions
diff --git a/build/win32/vs9/Makefile.am b/build/win32/vs9/Makefile.am
index f25c7ec..69af53f 100644
--- a/build/win32/vs9/Makefile.am
+++ b/build/win32/vs9/Makefile.am
@@ -1,18 +1,20 @@
+GENERATED_ITEMS = \
+ atk.vcproj \
+ atk-install.vsprops
+
EXTRA_DIST = \
README.txt \
atk.sln \
- atk.vcproj \
atk.vcprojin \
atk-install.vcproj \
atk-build-defines.vsprops \
atk-gen-src.vsprops \
- atk-install.vsprops \
atk-install.vspropsin \
- atk-version-paths.vsprops
-
-atk-install.vsprops: atk.vcproj
+ atk-version-paths.vsprops \
+ $(GENERATED_ITEMS)
-atk.vcproj:
- $(PYTHON) $(top_srcdir)/build/atk_msvc_files.py -t vs9
+atk-install.vsprops: $(top_srcdir)/build/win32/vs9/atk-install.vspropsin atk.headers
+ $(CPP) -P - <$(top_srcdir)/build/win32/vs9/atk-install.vspropsin >$@
+ rm atk.headers
-DISTCLEANFILES = atk.vcproj atk-install.vsprops
+DISTCLEANFILES = $(GENERATED_ITEMS)