summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorHavoc Pennington <hp@redhat.com>2001-06-07 16:39:50 +0000
committerHavoc Pennington <hp@src.gnome.org>2001-06-07 16:39:50 +0000
commitcdca5df66ffc95ce6451f8e9b989b557a7d83a46 (patch)
tree743affd17d7e0e1e9dc74a502ff186f91a3f75ce /configure.in
parent671b7ace2ba2a4ff813a8fb2e6799622cdfcb5fc (diff)
downloadatk-cdca5df66ffc95ce6451f8e9b989b557a7d83a46.tar.gz
subst GLIB_GENMARSHAL, GOBJECT_QUERY, GLIB_MKENUMS variables
2001-06-07 Havoc Pennington <hp@redhat.com> * m4macros/glib-2.0.m4: subst GLIB_GENMARSHAL, GOBJECT_QUERY, GLIB_MKENUMS variables * gmodule-2.0.pc.in: add gmodule_supported variable * glib-2.0.pc.in: add glib_genmarshal, gobject_query, glib_mkenums variables * configure.in: put G_MODULE_SUPPORTED value into .pc files * autogen.sh: support AUTOGEN_SUBDIR_MODE * Makefile.am: add -uninstalled.pc.in to EXTRA_DIST 2001-06-07 Havoc Pennington <hp@redhat.com> * pango/Makefile.am: add libpango.la to _DEPENDENCIES for the other libs * configure.in: use AM_PATH_GLIB_2_0 * autogen.sh: support AUTOGEN_SUBDIR_MODE * Makefile.am: dist the .pc.in files 2001-06-07 Havoc Pennington <hp@redhat.com> * atk/Makefile.am: use @GLIB_GENMARSHAL@ so we can use uninstalled glib-genmarshal * configure.in: rearrange the library checks to support uninstalled linking * autogen.sh: add support for AUTOGEN_SUBDIR_MODE * atk-uninstalled.pc.in: new file, allows linking to uninstalled ATK in giant GTK tarball 2001-06-07 Havoc Pennington <hp@redhat.com> * tests/Makefile.am: add missing -I flag * gtk/Makefile.am: use @GLIB_MKENUMS@, @GLIB_GENMARSHAL@, etc. * configure.in: use pkg-config to see if GModule is supported; fix to properly turn on included loaders when GModule isn't supported; don't use AC_CHECK_LIB when libs are not installed yet * autogen.sh: add support for AUTOGEN_SUBDIR_MODE * Makefile.am (SUBDIRS): add m4macros subdir * gtk/Makefile.am: $(srcdir)/foo targets must be $(srcdir)/foo in dependencies also.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in56
1 files changed, 15 insertions, 41 deletions
diff --git a/configure.in b/configure.in
index 52038dc..c1de6e1 100644
--- a/configure.in
+++ b/configure.in
@@ -24,57 +24,31 @@ if test "x$GCC" = "xyes"; then
fi
changequote([,])dnl
-
-#
-# Find pkg-config
-#
-AC_PATH_PROG(PKG_CONFIG, pkg-config, no)
-if test x$PKG_CONFIG = xno ; then
- AC_MSG_ERROR([*** pkg-config not found. See http://pkgconfig.sourceforge.net])
-fi
-
-if ! pkg-config --atleast-pkgconfig-version 0.5 ; then
- AC_MSG_ERROR([*** pkg-config too old; version 0.5 or better required.])
-fi
-
GLIB_PACKAGES="gobject-2.0 gmodule-2.0 gthread-2.0"
AC_SUBST(GLIB_PACKAGES)
GLIB_REQUIRED_VERSION=1.3.2
-AC_MSG_CHECKING(GLib version)
-if $PKG_CONFIG --atleast-version $GLIB_REQUIRED_VERSION glib-2.0 ; then
- AC_MSG_RESULT(yes)
-else
- AC_MSG_ERROR([
-*** GLIB $GLIB_REQUIRED_VERSION or newer is required. The latest version of GLIB
-*** is always available from ftp://ftp.gtk.org/.
- ])
-fi
-
PANGO_PACKAGES="pango"
AC_SUBST(PANGO_PACKAGES)
-# Check for Pango flags
+dnl This PATH_GLIB is somewhat redundant, but does a sanity compile and
+dnl importantly defines the GLIB_GENMARSHAL variable for subst into the
+dnl Makefile
+AM_PATH_GLIB_2_0($GLIB_REQUIRED_VERSION)
+
+PKG_CHECK_MODULES(DEP, glib-2.0 >= $GLIB_REQUIRED_VERSION $GLIB_PACKAGES $PANGO_PACKAGES, , AC_MSG_ERROR([
+ *** GLib or Pango not found. You can find these on ftp://ftp.gtk.org
+ *** Errors follow:
+ $DEP_PKG_ERRORS]))
-AC_MSG_CHECKING(Pango version)
-if $PKG_CONFIG --exists $PANGO_PACKAGES ; then
- AC_MSG_RESULT(yes)
+if $PKG_CONFIG --uninstalled $GLIB_PACKAGES $PANGO_PACKAGES; then
+ :
else
- AC_MSG_ERROR([
-*** Pango not found. Pango is required to build ATK.
-*** See http://www.pango.org for Pango information.
-])
+ AC_CHECK_LIB(pango, pango_context_new, :, AC_MSG_ERROR([
+ *** Can't link to Pango. Pango is required to build
+ *** GTK+. For more information see http://www.pango.org]), $DEP_LIBS)
fi
-DEP_CFLAGS=`$PKG_CONFIG --cflags $GLIB_PACKAGES $PANGO_PACKAGES`
-DEP_LIBS=`$PKG_CONFIG --libs $GLIB_PACKAGES $PANGO_PACKAGES`
-AC_SUBST(DEP_CFLAGS)
-AC_SUBST(DEP_LIBS)
-
-AC_CHECK_LIB(pango, pango_context_new, :, AC_MSG_ERROR([
-*** Can't link to Pango. Pango is required to build
-*** GTK+. For more information see http://www.pango.org]), $DEP_LIBS)
-
AC_CHECK_PROG(GTKDOC, gtkdoc-mkdb, true, false)
gtk_doc_min_version=0.6
@@ -122,10 +96,10 @@ if test "x$enable_rebuilds" = "xyes" && \
fi
AC_SUBST(REBUILD)
-
AC_OUTPUT([
Makefile
atk.pc
+atk-uninstalled.pc
atk/Makefile
tests/Makefile
docs/Makefile