summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorOwen Taylor <otaylor@redhat.com>2001-06-09 19:20:04 +0000
committerOwen Taylor <otaylor@src.gnome.org>2001-06-09 19:20:04 +0000
commit5f8117526e078cdcf985be2985a572713a9e0c9a (patch)
tree6e126798dea358325c1c10edfec5b923f7dcd547 /configure.in
parent6731a5a3e5daf84b2983924cec0c8a3102268522 (diff)
downloadatk-5f8117526e078cdcf985be2985a572713a9e0c9a.tar.gz
Only include gthread-2.0 in CFLAGS, not in LIBS. (Always linking with
Sat Jun 9 15:17:00 2001 Owen Taylor <otaylor@redhat.com> * configure.in (DEP_CFLAGS): Only include gthread-2.0 in CFLAGS, not in LIBS. (Always linking with -lpthread is a noticeable speed hit.)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index c1de6e1..9fa0cd6 100644
--- a/configure.in
+++ b/configure.in
@@ -24,7 +24,7 @@ if test "x$GCC" = "xyes"; then
fi
changequote([,])dnl
-GLIB_PACKAGES="gobject-2.0 gmodule-2.0 gthread-2.0"
+GLIB_PACKAGES="gobject-2.0 gmodule-2.0"
AC_SUBST(GLIB_PACKAGES)
GLIB_REQUIRED_VERSION=1.3.2
@@ -41,6 +41,9 @@ PKG_CHECK_MODULES(DEP, glib-2.0 >= $GLIB_REQUIRED_VERSION $GLIB_PACKAGES $PANGO_
*** Errors follow:
$DEP_PKG_ERRORS]))
+# Rerun PKG_CONFIG to add gthread-2.0 cflags, but not libs
+DEP_CFLAGS=`$PKG_CONFIG --cflags $GLIB_PACKAGES $PANGO_PACKAGES gthread-2.0`
+
if $PKG_CONFIG --uninstalled $GLIB_PACKAGES $PANGO_PACKAGES; then
:
else