summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChun-wei Fan <fanchunwei@src.gnome.org>2013-12-16 11:25:36 +0800
committerChun-wei Fan <fanchunwei@src.gnome.org>2013-12-16 11:27:03 +0800
commit56e07beb2df88f6b27cc647eea5b00bfc4ab34a1 (patch)
tree5bc48c79278eb4cebfce1302768e556f4f9d14ac /configure.ac
parentc403ddfa064ef3ffaa908fae6323de0dd2519b7d (diff)
downloadatk-56e07beb2df88f6b27cc647eea5b00bfc4ab34a1.tar.gz
build: Use Python to Generate the MSVC Projects
This would move the generation of the ATK Visual C++ 2008/2010 project to Python 2/3 scripts from autotools scripts. This would have the following advantages: -Reduce congestion in the autotools files, most notably atk/Makefile.am, and make everything that concerns the completion of MSVC project files fo under build/ -Easier to maintain and test, as a standard installation of Python (even on Windows) is enough to generate the Project files, and this can still be easily called during 'make dist'. -Also paves the first steps for people wanting to build ATK from a GIT checkout, as this will help simplify the process There is now a dependency on Python 2/3 for people that are wishing to do 'make dist', as naturally the scripts to do the Visual C++ project generation is done with Python, but since one is likely going to generate the .gir files for ATK when doing 'make dist'/'make distcheck', this is satisfied as the scripts used to generate the .gir files are Python 2.6+ scripts as well. https://bugzilla.gnome.org/show_bug.cgi?id=690145
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 8478a1b..3b2d309 100644
--- a/configure.ac
+++ b/configure.ac
@@ -215,6 +215,20 @@ if test "x$enable_rebuilds" = "xyes" && \
fi
AC_SUBST(REBUILD)
+# option to specify python interpreter to use; this just sets $PYTHON, so that
+# we will fallback to reading $PYTHON if --with-python is not given, and
+# python.m4 will get the expected input.
+# This dependency on Python is for 'make dist', so normal builds would not
+# need Python
+AC_ARG_WITH(python,
+ AS_HELP_STRING([--with-python=PATH],
+ [Path to Python interpreter; searches $PATH if only a program name is given; if not given, searches for a few standard names such as "python3" or "python2"]),
+ [PYTHON="$withval"], [])
+if test x"$PYTHON" = xyes; then
+ AC_MSG_ERROR([--with-python option requires a path or program argument])
+fi
+AM_PATH_PYTHON(2.5,,PYTHON="/usr/bin/env python2.5")
+
GNOME_COMPILE_WARNINGS([maximum])
AC_CONFIG_FILES([