summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChun-wei Fan <fanchunwei@src.gnome.org>2015-07-21 13:05:56 +0800
committerChun-wei Fan <fanchunwei@src.gnome.org>2015-09-17 09:33:21 +0800
commit510fc6a4da93a9c1bedb0ad83ebf12635b542ba4 (patch)
tree42ff2497b54d72695a148fb2327dafa074770a16 /configure.ac
parent9ae6ef5456022e17c3f84d74252d89e10ae53766 (diff)
downloadatk-510fc6a4da93a9c1bedb0ad83ebf12635b542ba4.tar.gz
configure.ac: Remove Check For Python
Since we are now using the common autotools module for generating the complete Visual Studio ATK projects, we don't need to check for Python anymore during configure, so we can just drop the Python part. https://bugzilla.gnome.org/show_bug.cgi?id=755114
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 0 insertions, 14 deletions
diff --git a/configure.ac b/configure.ac
index f5c27bf..2042da4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -215,20 +215,6 @@ if test "x$enable_rebuilds" = "xyes" && \
fi
AC_SUBST(REBUILD)
-# option to specify python interpreter to use; this just sets $PYTHON, so that
-# we will fallback to reading $PYTHON if --with-python is not given, and
-# python.m4 will get the expected input.
-# This dependency on Python is for 'make dist', so normal builds would not
-# need Python
-AC_ARG_WITH(python,
- AS_HELP_STRING([--with-python=PATH],
- [Path to Python interpreter; searches $PATH if only a program name is given; if not given, searches for a few standard names such as "python3" or "python2"]),
- [PYTHON="$withval"], [])
-if test x"$PYTHON" = xyes; then
- AC_MSG_ERROR([--with-python option requires a path or program argument])
-fi
-AM_PATH_PYTHON(2.5,,PYTHON="/usr/bin/env python2.5")
-
# Check for the visibility flags
ATK_HIDDEN_VISIBILITY_CFLAGS=""
case "$host" in