summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorPatryk Kaczmarek <patryk.k@samsung.com>2015-09-29 12:33:07 +0200
committerMike Gorse <mgorse@suse.com>2015-11-18 19:31:49 -0600
commit21d493d78b5e2d16a757fcc05f33c78264f2d609 (patch)
tree4e3e5b758d0fd591a3c776c272a7799cfd3e6840 /tests/Makefile.am
parenta084e019632c28f9eb61524294a31f3e659430c7 (diff)
downloadat-spi2-atk-21d493d78b5e2d16a757fcc05f33c78264f2d609.tar.gz
Next tests for accessible interfaces
* New tested interfaces: - Collection - EditableText - Image - Text - Value * Commented tests for depricated function in Component tests deleted * Unused variables deleted * Added compilation flag -Wall
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am19
1 files changed, 14 insertions, 5 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 66edcf9..0ac1ca7 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -11,7 +11,8 @@ atk_test_CFLAGS = $(DBUS_CFLAGS) \
-I$(top_srcdir)/tests/dummyatk/ \
-I$(top_builddir)/tests/dummyatk/.libs \
-I$(top_builddir)/tests/dummyatk/.deps \
- -I$(top_srcdir)
+ -I$(top_srcdir) \
+ -Wall
atk_test_LDADD = libxmlloader.la \
libtestutils.la \
@@ -27,13 +28,19 @@ atk_test_SOURCES = atk_suite.c \
atk_suite.h \
atk_test_accessible.c \
atk_test_action.c \
- atk_test_component.c
+ atk_test_component.c \
+ atk_test_collection.c \
+ atk_test_editable_text.c \
+ atk_test_image.c \
+ atk_test_text.c \
+ atk_test_value.c
app_test_CFLAGS = -I$(top_builddir) \
$(GLIB_CFLAGS) \
$(ATK_CFLAGS) \
-I$(top_srcdir)/tests/dummyatk \
- -I$(top_srcdir)/atk-adaptor
+ -I$(top_srcdir)/atk-adaptor \
+ -Wall
app_test_LDADD = libxmlloader.la \
libtestutils.la \
@@ -48,7 +55,8 @@ libxmlloader_la_CFLAGS = $(GLIB_CFLAGS) \
$(GOBJ_CFLAGS) \
$(XML_CFLAGS) \
$(ATK_CFLAGS) \
- -I$(top_srcdir)/tests/dummyatk/
+ -I$(top_srcdir)/tests/dummyatk/ \
+ -Wall
libxmlloader_la_LIBADD = $(GLIB_LIBS) \
$(XML_LIBS) \
@@ -61,7 +69,8 @@ libxmlloader_la_SOURCES = atk-object-xml-loader.c\
libtestutils_la_CFLAGS = -I$(top_builddir) \
$(GLIB_CFLAGS) \
- $(ATSPI_CFLAGS)
+ $(ATSPI_CFLAGS) \
+ -Wall
libtestutils_la_LIBADD = $(GLIB_LIBS) \
$(ATSPI_LIBS)